Problemino con il controllo asp:ImageButton

venerdì 01 gennaio 2010 - 12.51

sandrodp Profilo | Newbie

Salve ragà,

sono nuovo del forum e scusatemi in anticipo delle cavolate che scriverò ....

Allora io ho su una mia pagina .aspx diversi controlli ImageButton con la proprietà PostBackUrl= che mi rimanda al sito da me desiderato.

in alcuni controlli tutto ok !!! tutto funziona perfettamente clicco e mi si apre il sito da me indicato.

negli ultimi controlli invece che ho inserito e che utilizzo nello stesso modo invece mi ritorna il messaggio di errore "The page cannot be displayed" error http 405.

il tutto lo potete provare al seguente link : www.ecoclimacasa.it/Link.aspx

infatti i link dei partner i primi 3 tramite le imageButton funzionano.
l'ultimo ImageButton della pagina invece mi porta all'errore.

non riesco a capire dove sia la differenza e se dipende dal mio lato o dal lato del sito che invoco ?????

Spero in alcune informazioni e delucidazioni da parte degli esperti quì.

Byee Sandro

FrancescoGuadagno Profilo | Senior Member

Sembra un problema del sito che cerchi di raggiungere, perchè infatto in semplice refresh risolve il problema.
Prova a puntare non a
www.dominio.it
ma a
www.dominio.it/index.htm

che è in effetti la pagina che viene renderizzata.

Gluck74 Profilo | Guru

Concordo, non mettere solo il dominio, ma anche la pagina specifica.
ciao

sandrodp Profilo | Newbie

non è cambiato nulla l'errore persiste anche mettendo l'intero URL del sito.

Poi che cambia... negli altri ImageButton lo usato e ha funzionato.
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5