Sapete dirmi che errore è?

mercoledì 06 gennaio 2010 - 02.02

trinity Profilo | Guru

ho utilizzato la meccanica del publish di visual studio per pubblicare su un server ftp una mia webapplication.

appena avvio la pagina web mi esce questo errore:

<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">


sapete dirmi da cosa dipende e semmai come poterlo sistemare?

Ciao
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

Ciao
>appena avvio la pagina web mi esce questo errore:
><sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
>sapete dirmi da cosa dipende e semmai come poterlo sistemare?
Quella è semplicemente una riga del web config in cui definisci che userai ajax.. però dovresti cortesemente postare la parte di web config delle section e dei section group per capire se hai creato bene il file di configurazione. In alternativa, se non hai già aggiunto voci al web.config, puoi rinominarlo e farne uno nuovo provando a ricompilare.
L'errore a mio avviso non è quello che hai postato, ma una cosa tipo:

"Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system
cannot find the file specified."

se così è potresti leggere questi post:
http://forums.asp.net/t/1062125.aspx
http://forums.asp.net/t/1135367.aspx
http://bytes.com/topic/asp-net/answers/586766-could-not-load-file-assembly-system-web-extensions

leggi qui per maggiori informazioni
http://msdn.microsoft.com/it-it/library/bb546044.aspx
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

Questa è la paggina che mi appare in explorer:

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'type'.

Source Error:


Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

questa è la mia web.config pubblicata:

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra



se vuoi ti posto anche il webconfig
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

>Description: An error occurred during the processing of a configuration
>file required to service this request. Please review the specific
>error details below and modify your configuration file appropriately.
>se vuoi ti posto anche il webconfig
hai provato a rifarlo daccapo? ti dà lo stesso errore?
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

come faccio a rifare il web.config?
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

>come faccio a rifare il web.config?
destro sul progetto, destro del mouse e Add --> New Item.. Web Configuration File.
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

Ricreato ma sempre lo stesso errore

ecco il nuovo web.config:

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

ciao
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

>Ricreato ma sempre lo stesso errore
hai provato a leggere i link che ti ho passato all'inizio? Leggi con attenzione, secondo me c'è la soluzione.

--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

Da come ho potuto capire è un discorso che ajax sul server web non è installato.
Pertanto la mia domanda è la seguente: Con visual studio è possbile non utilizzare ajax o cmq il suo linguaggio per creare una webapplication?

Se si come?

ciao e grazie
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

>Pertanto la mia domanda è la seguente: Con visual studio è possbile
>non utilizzare ajax o cmq il suo linguaggio per creare una webapplication?
Ah, io credevo che usassi ajax

>Se si come?
che visual studio hai?
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

Io ho visual studio 2008 ma ho un sito internet presso un provider anzi 2 siti presso due provider diversi e ad entrambi ho pubblicato la mia webapplication ed ad entrambi mi da lo stesso errore
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

>Io ho visual studio 2008 ma ho un sito internet presso un provider
>anzi 2 siti presso due provider diversi e ad entrambi ho pubblicato
>la mia webapplication ed ad entrambi mi da lo stesso errore
Cambia il Target Framework a 2.0 e rifai il web.config, ho paura che non supporti il 3.5
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

alx_81 Profilo | Guru

>Io ho visual studio 2008 ma ho un sito internet presso un provider
>anzi 2 siti presso due provider diversi e ad entrambi ho pubblicato
>la mia webapplication ed ad entrambi mi da lo stesso errore
Il progetto di che tipo è? Com'è stato creato? Sembra che i server di destinazione non abbiano l'ajax toolkit
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

Da cm ho capito manca proprio quello.
Il progetto una webapplication semplice fatta con visual studio 2008 con linguaggio vb.
connectionstring su un db sqlserver 2008.

se dovesse mancare proprio l'ajax toolkit come faccio?

Se ti serve sapere altro dimmi
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

>Da cm ho capito manca proprio quello.
>Il progetto una webapplication semplice fatta con visual studio
>2008 con linguaggio vb.
>connectionstring su un db sqlserver 2008.
>
>se dovesse mancare proprio l'ajax toolkit come faccio?
in teoria non dovresti averlo, mi sembra più un'applicazione web Ajax. Per curiosità fai un nuovo progetto e vedi se con il web.config standard va.
Il metodo da seguire successivpìo è eliminare tutte le sezioni di ajax cercando "System.Web.Extensions" ed eliminando i riferimenti sia nelle sezioni sia sotto nel resto del web.config.
Sempre che non usi ajax
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

cmq ora ho creato un progetto website...ho inserito un pò di roba ed in locale gira le connessioni al db remoto funzionano...eseguo la compilazione del sito e poi sempre con visual studio lo pubblico.. e mi rida lo stesso errore eppure ora non ho usato la webapplication

come mai? cmq ecco la url:

http://www.wnetstudios.com/fr/default2.aspx

ciao

Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

sandrodp Profilo | Newbie

chi sono i tuoi fornitori di spazio web ??? dovresti chiedere a loro cosa ti offrono se il supporto a 3.5 di framework, e quale versione ajax e sqlserver ti danno.

Secondo me è tutto lì il problema.

alx_81 Profilo | Guru

>chi sono i tuoi fornitori di spazio web ??? dovresti chiedere
>a loro cosa ti offrono se il supporto a 3.5 di framework, e quale
>versione ajax e sqlserver ti danno.
io registro i domini su godaddy.com di solito e lo spazio web e database su databasemart.com
prova server di test free (credo che aruba ne abbia) e guarda se hai problemi di sorta.
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

in pratica compilando il sito con il framework 2.0 (l'ho cambiato dalle proprietà del progetto) questo errore non me lo da + ma quando pubblico tutto mi dice questo:

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

calcola che il sito è pubblicato su un server e il db invece si trova su un altro serve remoto che funziona ed è raggiungibile tranquillamente. In pratica la pagina web deve puntare il database che si trova su un altro server (non web).
sul mio pc funziona tutto. potrebbe che sul server non c'è il framework 2.0 perchè in basso alla fine dell'errore esce la versione del framework ed è la 1.1.4

Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

alx_81 Profilo | Guru

>in pratica compilando il sito con il framework 2.0 (l'ho cambiato
>dalle proprietà del progetto) questo errore non me lo da + ma
>quando pubblico tutto mi dice questo:
>sul mio pc funziona tutto. potrebbe che sul server non c'è il
>framework 2.0 perchè in basso alla fine dell'errore esce la versione
>del framework ed è la 1.1.4
posta il web.config che usi così ci arriviamo in fondo
--

Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

trinity Profilo | Guru

allora sul server in cui gira il sito internet ho fatto installare il framework 2.0 ora ecco quando avvio il sito mi da questo errore:

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

ecco il web.config del sito:

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

invece ecco il web.config della webapplication:

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra



ad entrambi mi esce lo stesso errore sopracitato
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5