Asp net 3.5/App Code/Classe funzionante su pc ma non on line....help

sabato 06 marzo 2010 - 00.05

flavio70 Profilo | Newbie

Salve a tutti. Ho un grosso problema. Ho creato alcune classi direttamente nella cartella App Code ( visual studio 2008) del mio sito web. Alcune funzionano egregiamente anche on line, altre invece funzionano nel mio pc, ma non quando pubblico il tutto...Non capisco...Sono davvero perplesso...Qualcuno di voi mi può illuminare? La classe interessata non contiene oggetti o riferimenti particolari; niente che non sia presente anche nelle altre classi, funzionanti. Esegue un insieme di operazioni matematiche e restituisce una stringa, composta attraverso una serie di interrogazioni su file xml attraverso linq. Il problema è che, una volta generata la stringa, continua a ripeterla qualunque sia l'interrogazione, mentre invece quando faccio girare il progetto nel mio pc...bè, miracolosamente tutto funziona...

la pagina web interessata è composta da alcuni user control, una master page, e un po' di update panels conditi da qualche effetto ajax. I riferimenti si limitano a linq, xml.linq, e math.

Al momento, medito di riscrivere tutto il codice in una classe precompilata e caricarla nella cartella bin, e vedere cosa succede; siccome è un lavoraccio, spero davvero che arrivi prima qualche suggerimento...

Il mio livello di programmazione è amatoriale, se non si era ancora capito ;)

grazie a tutti
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5