Caratteri speciali non riconosciuti

venerdì 14 gennaio 2011 - 12.02
Tag Elenco Tags  C#  |  .NET 3.5  |  Visual Studio 2008  |  MySQL 5.0

Gemini Profilo | Expert

Ciao a tutti
Ho inserito in un sito l'editor presente nell'ajaxtoolkit e ho notato che al posto di caratteri tipo: è, à e altri caratteri speciali(il sito è anche in spagnolo e ci sono molti caratteri speciali), inserisce ? quando salvo sul db.
Ho inserito nella pagina:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

Utilizzo un db mesql.
Ora non so se il problema dipende dall'Editor, da mysql o dalla pagina.
Grazie mille

alx_81 Profilo | Guru

>Ciao a tutti
Ciao

>Ora non so se il problema dipende dall'Editor, da mysql o dalla pagina.
Dove li vedi i ? sulla pagina in render oppure se fai la query direttamente da db server?

>Grazie mille
di nulla!
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Gemini Profilo | Expert

Ciao
ho fatto il debug e mi da ? quando faccio:
azienda.ChiSiamo = txtChiSiamo.Content.Trim();

questo è il globalization del web.config:
<globalization culture="auto" uiCulture="auto:it-IT" fileEncoding="utf-8" requestEncoding="utf-8" responseEncoding="utf-8" responseHeaderEncoding="utf-8" />

Non so se può essere utile:
Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

<customAjax:CustomEditor ID="txtChiSiamo" runat="server" AutoFocus="False" Height="200px"
Width="460px" EnableTheming="False" CssClass="text_box" />
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5