Firofox non mi fa scaricare documenti da pagine asp

martedì 08 febbraio 2011 - 21.01
Tag Elenco Tags  Windows XP  |  Firefox

geppetto_1955 Profilo | Newbie

Buona sera a tutti!
Sono nuovo (e poco pratico di asp) e sono capitato qui dopo una ricerca in internet.
Ho il seguente problema:
utilizzo Firefox (ver. 3.6.13) come browser su Windows XP-SP3 (aggiornato), e non riesco a visualizzare-scaricare documenti da una pagina contenente (ho letto il sorgente) istruzioni del tipo:

<form method="post" action="download.asp">
<input type="hidden" name="nome" value="101 Sapienza di Dio I-God's wisdom I.zip">
<td width="195" align="left" valign="baseline"><a href="#" onClick="submit()" title="101 Sapienza di Dio I-God's wisdom I" style="text-decoration: none"><font color="#000000" size="2" face="Arial, Helvetica, sans-serif">&nbsp;
<strong>101 Sapienza di Dio I-God</strong></font></a></td>
</form>

Premetto che visitando lo stesso sito da un altro computer è possibile scaricare i documenti.
Non sono riuscito a trovare cosa c'è che non va.
Non riesco a capire perché il tag '<a href' ha come valore "#": forse è per questo che non scarica niente.
Effettivamente nella Status-bar il link che visualizza passando il cursore del mouse su un documento è:
http://www.diffondilaparola.com/home.asp?tipo=20#
naturalmente manca il seguito del link che dovrebbe essere: "101 Sapienza di Dio I-God's wisdom I.zip"

Spero in un vostro aiuto.
Grazie anticipatamente

Geppetto

alx_81 Profilo | Guru

>Buona sera a tutti!
ciao e benvenuto su dotnethell!

>Premetto che visitando lo stesso sito da un altro computer è
>possibile scaricare i documenti.
>Non sono riuscito a trovare cosa c'è che non va.
>Non riesco a capire perché il tag '<a href' ha come valore
>"#": forse è per questo che non scarica niente.
>Effettivamente nella Status-bar il link che visualizza passando
>il cursore del mouse su un documento è:
>http://www.diffondilaparola.com/home.asp?tipo=20#
>naturalmente manca il seguito del link che dovrebbe essere: "101
>Sapienza di Dio I-God's wisdom I.zip"
aprendo e controllando quel link con firebug, noterai che non c'è nessuna funziona submit() definita. Quindi il sito non funziona a nessuno.
Su altri pc forse andava per ragioni di cache ancora non aggiornata..

>Grazie anticipatamente
di nulla!
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

damabianca Profilo | Newbie

Infatti.
Non preoccuparti quindi
Forum
http://www.lavalledelleco.net/

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5