Problema con gpedit.msc

giovedì 10 febbraio 2011 - 17.30
Tag Elenco Tags  VBScript

Eldest139 Profilo | Newbie

Ciao a tutti
ho da poco sviluppato uno script in vbs grazie alle dritte di alcuni utenti del forum, comunque una volta ultimano ho inserito lo script in criteri di gruppo >configurazione utente>impostazioni di windows >script di accesso/ fine sessione. Dato che non ho la necessità di lanciare lo script a ogni riavvio ho creato un file txt semaforo , all'interno ho inserito uno zero , così quando riavvio il pc manualmente al successivo riavvio lo script controlla il file semaforo legge lo zero e muore. Se invece ho riavviato il pc tramite un altro script (che prima di riavviare sostituisce lo zero con 1) al riavvio lo script legge l'uno presente all'interno del file semaforo e inizia il suo lavoro ( disabilità l'auto logon abilitato dal precedente script,cambia l'uno del file semaforo in zero ed infine esegue un software). Fin qui tutto normale , l'unica cosa anomala è che se testo il suddetto script cliccandoci sopra , funziona correttamente , se lo inserisco in in script di accesso al riavvio lo script parte esegue le operazioni prestabilite ma una volta eseguito il software questo si chiude in un millesimo di secondo.. qualcuno mi può aiutare??? grazie anticipatamente

luigidibiasi Profilo | Guru

credo che se metti in avvio automatico uno script quando si avvia la sessione (è terminal server?) non si avvia la shell explorer ma solo quel programma... (dunque una volta terminato lo script non ha altro da fare la sessione e si chiude)

Luigi Di Biasi


http://www.dibiasi.it/
http://netsell.dibiasi.it - ecomm software -
http://blogs.dotnethell.it/luigidibiasi/
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5