Non Stampa field del database

giovedì 05 maggio 2011 - 11.47

rosspw Profilo | Newbie

Salve a tutti...

Vengo subito al problema, devo aggiungere un campo di un database non collegato al report.
Devo aggiornare le stampe di un software gestionale di cui non ho + assistenza.
Sono obbligato ad utilizzare CR 8 per compatibilità con sw gestionale.
inserisco il campo, vedendo che non è collegato ancora questo database, lo collego...
Quindi collego il database al report, inserisco il campo e fin qui tutto OK.
In stampa però non mi visualizza niente.
Il fatto strano è che questo campo in altri report funziona benissimo (già esistenti).
Una cosa che ho notato è che se inserisco un campo qualsiasi di un database già collegato questo me lo visualizza in stampa, anche del database interessato...

Grazie in anticipò x l'aiuto...

Ciao!

babbubba Profilo | Senior Member

>inserisco il campo, vedendo che non è collegato ancora questo
>database, lo collego...
>Quindi collego il database al report, inserisco il campo e fin
>qui tutto OK.
>In stampa però non mi visualizza niente.
>Il fatto strano è che questo campo in altri report funziona benissimo
>(già esistenti).

Quando dici 'collego il database al report' a cosa ti riferisci.... come popoli il datasource del report?

>Una cosa che ho notato è che se inserisco un campo qualsiasi
>di un database già collegato questo me lo visualizza in stampa,
>anche del database interessato...
>

Qui nn ti ho capito... perdonami...
Babbubba

www.bsoftsolutions.it

Chiedere è curiosità ... rispondere è educazione.

rosspw Profilo | Newbie

Nemmeno io comprendo:
"come popoli il datasource del report?"

Cmq carico il report, mi connetto al server, poi Database/Add Database to Report, seleziono quello interessato quindi mi appare il Visual Linking Expert con tutte le connessioni tra le Tabelle.

Esco e torno al report, ora mi da la possibilità di inserire anche i campi di quel database, il problema è che non me li visualizza in stampa.

Grazie...

babbubba Profilo | Senior Member

Io uso un'approccio diverso con i report di crystal...

Uno creo un dataset nel progetto vb con la tabella contenente la struttura dei dati da inserire nel report.
Creo il report vuoto e dopo associo lo stesso ad una sorgente dati del progetto... il mio dataset per la precisione indicando la tabella fatta apposta.

Poi al momento opportuno popolo una datatable che eredita la struttura dal dataset con i dati che voglio stampare nel report...

Istanzio il report e associo il data source del report alla datatable.

-------

Credo che il tuo problema sia che non esegui alcun fetch tra i record del datatble... ti ripeto che il mio approccio è diverso quindi non so come aiutarti... aspetta il parere di qualcuno piu esperto.

Bya



Babbubba

www.bsoftsolutions.it

Chiedere è curiosità ... rispondere è educazione.

rosspw Profilo | Newbie

Ok, intanto grazie... attendo news, spero a breve...

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5