Browser non vede Cassini

giovedì 26 maggio 2011 - 18.04

Explorer83 Profilo | Newbie

Ciao ragazzi, ho un problema che mi sta facendo stritolare le cervella e non riesco a risolverlo, ma qui al lavoro cominciano a fare pressioni per cui spero che mi possiate aiutare.

Ho un progetto web in Visual Studio 2008, il debug ha sempre funzionato bene, fin quando ho dovuto formattare l'harddisk e reinstallare tutto.
Da quel momento quando avvio il progetto, Cassini si avvia, ma Internet Explorer non ne vuole sapere di avviarsi. Se prendo l'indirizzo (http://localhost:porta/) e lo incollo sul browser, stesso risultato, mi dice "Internet Explorer: impossibile visualizzare la pagina Web".
Quando poi stoppo Cassini mi appare il messaggio d'errore "Unable to connect to ASP.NET Development Server", messaggio che con Google ho cercato in lungo e largo ma senza trovare nulla che faccia al caso mio.

Per essere esaustivi vi dico un po' l'iter che ho seguito.
Ho formattato e installato Windows 7 Ultimate. Poi ho installato in sequenza VS2005, ServicePack1 di VS2005, VS2008, ServicePack1 di VS2008, e VS2010. Subito dopo SQLServer 2008.
Verificata la presenza del problema ho disinstallato nell'ordine VS2010, VS2008, VS2005.
A questo punto ho reinstallato il solo VS2008 con il ServicePack 1 e ho updatato Windows 7.
Quindi attualmente dispongo del solo VS2008 su Windows 7 Ultimate updatato.

Spero tanto in un vostro aiuto perchè non so più che pesci prendere! :(

Brainkiller Profilo | Guru

>Da quel momento quando avvio il progetto, Cassini si avvia, ma
>Internet Explorer non ne vuole sapere di avviarsi. Se prendo
>l'indirizzo (http://localhost:porta/) e lo incollo sul browser,
>stesso risultato, mi dice "Internet Explorer: impossibile visualizzare
>la pagina Web".

E se usi un altro browser, uguale ?

>Per essere esaustivi vi dico un po' l'iter che ho seguito.
>Ho formattato e installato Windows 7 Ultimate. Poi ho installato
>in sequenza VS2005, ServicePack1 di VS2005, VS2008, ServicePack1
>di VS2008, e VS2010. Subito dopo SQLServer 2008.

Ma dove nasce scusa questa sequenza ? Veramente originale.

>Spero tanto in un vostro aiuto perchè non so più che pesci prendere!

Perchè non usi IIS ?

Ciao

David De Giacomi | <empty>
http://blogs.dotnethell.it/david/

Explorer83 Profilo | Newbie

Se uso un altro browser stessa storia.
Ho installato tutti e tre i VS perchè ho in effetti bisogno di tutt'e tre le versioni qui al lavoro.
Accolgo il suggerimento e provo ad installare IIS per vedere se riesco temporaneamente a risolvere, in ogni caso resterebbe però un bel mistero!

Cmq mi sa che per sbaglio ho premuto "Accetta" alla tua risposta, prego gli amministratori di far tornare il thread allo stato "non risolto".

Brainkiller Profilo | Guru

>Se uso un altro browser stessa storia.
>Ho installato tutti e tre i VS perchè ho in effetti bisogno di
>tutt'e tre le versioni qui al lavoro.

Ma perchè usi tutti e 3 ?
Teoricamente basterebbe il 2010 per operare su tutte le soluzioni precedenti.

>Accolgo il suggerimento e provo ad installare IIS per vedere
>se riesco temporaneamente a risolvere, in ogni caso resterebbe
>però un bel mistero!

Sicuramente, ma io personalmente non ho mai usato il web server interno.
potresti provare via telnet a fare un telnet localhost porta_cassini vedere se risponde o meno o è proprio chiuso.

>Cmq mi sa che per sbaglio ho premuto "Accetta" alla tua risposta,
>prego gli amministratori di far tornare il thread allo stato
>"non risolto".

Ho provveduto ed è tornato "non risolto"
Ciao

David De Giacomi | <empty>
http://blogs.dotnethell.it/david/

Explorer83 Profilo | Newbie

Perchè lavoro su svariati progetti sviluppati ognuno con una versione diversa, per usare ad esempio VS2010 per lavorare su una soluzione 2005 dovremmo fare la conversione, cosa che non ci è concessa.

Explorer83 Profilo | Newbie

Ho provato la connessione telnet e il responso è:
"Impossibile aprire una connessione con l'host sulla porta 15216: Connessione non riuscita"

Brainkiller Profilo | Guru

>Ho provato la connessione telnet e il responso è:
>"Impossibile aprire una connessione con l'host sulla porta 15216:
>Connessione non riuscita"

Ok,
allora è evidente che se il cassini dice che è in ascolto su quella porta, o mente, oppure su quella porta c'è qualcos'altro, oppure hai a bordo qualcosa (firewall, antivirus, ecc.) che bloccano le connessioni a quella porta, non vedo altri motivi possibilii.

Prova a fare anche un ping localhost e vedi che IP ti restituisce se quello della macchina locale o un altro.

Ciao


David De Giacomi | <empty>
http://blogs.dotnethell.it/david/

Explorer83 Profilo | Newbie

Facendo un ping localhost mi restituisce l'IP locale 127.0.0.1.
Ho disinstallato l'antivirus e ho disattivato il firewall di windows!

L'avevo detto che non so più che pesci prendere! :(
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5