Leggere e scrivere testo in un campo blob

martedì 12 luglio 2011 - 17.55
Tag Elenco Tags  C#  |  .NET 2.0  |  MySQL 5.0

kduhcm Profilo | Junior Member

Ciao,
come leggo e scrivo testo in un campo blob? Non devo scrivere o leggere file, ma semplicemente testo.
-----------------------------------------------------------------------------------------------------------------------
Sviluppo siti web Roma http://www.actasoftware.com

Gluck74 Profilo | Guru

testo in un campo BLOB?????
stai sbagliando, non è il suo utilizzo.

Questo tipo di dati è prima di tutto binario, e serve per memorizzare grosse quantità di dati (file, immagini, audio, ecc..)
(BLOB: Binary Large OBject)


____________
Ricordati di utilizzare il tasto "Accetta" se i nostri consigli ti sono serviti a risolvere il problema.
È il modo per ringraziare chi ti ha aiutato.

kduhcm Profilo | Junior Member

In effetti mi sto arrampicando sugli specchi. Volevo storicizzarci il cirillico visto che non riesco a gestirlo con i campi longtext. le ho provate tutte, utf8 cp1251 ma nisba.
-----------------------------------------------------------------------------------------------------------------------
Sviluppo siti web Roma http://www.actasoftware.com

Gluck74 Profilo | Guru

qual'è il tuo problema di preciso?

____________
Ricordati di utilizzare il tasto "Accetta" se i nostri consigli ti sono serviti a risolvere il problema.
È il modo per ringraziare chi ti ha aiutato.

kduhcm Profilo | Junior Member

Ci sto per rinunciare.
Devo storicizzare testo in cirillico sul database. In locale funziona bene, anche eseguendo il sito e puntando al db su aruba. Ma se pubblico su aruba e leggo lo stesso db, mi scrive i caratteri come punti interrogativi. Ho provato anche su un server diverso da aruba ma niente. Ho settato le tabelle e il db prima a utf8, poi a cp1251 ma il risultato e' sempre lo stesso.
-----------------------------------------------------------------------------------------------------------------------
Sviluppo siti web Roma http://www.actasoftware.com

Gluck74 Profilo | Guru

hai settato anche le impostazioni su web.config?
un esempio:

nella sezione system.web
<globalization requestEncoding="UTF-16" responseEncoding="UTF-16" fileEncoding="UTF-16" culture="it-IT" uiCulture="it-IT"/>
piuttosto che
<globalization requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>

____________
Ricordati di utilizzare il tasto "Accetta" se i nostri consigli ti sono serviti a risolvere il problema.
È il modo per ringraziare chi ti ha aiutato.

kduhcm Profilo | Junior Member

metto questo nella master page
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

e questo nel web config
<globalization requestEncoding="utf-8" responseEncoding="utf-8" responseHeaderEncoding="utf-8" fileEncoding="utf-8" />
-----------------------------------------------------------------------------------------------------------------------
Sviluppo siti web Roma http://www.actasoftware.com
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5