Autenticazione WS-Security

giovedì 28 luglio 2011 - 11.30
Tag Elenco Tags  VB.NET  |  .NET 2.0  |  Windows 7  |  Visual Studio 2008

io.alessio Profilo | Newbie

Ciao a tutti!

Devo implementare dei webservice con autenticazione WS-Security (username and password token in clear text senza nonce), sviluppo in vb con vs2008.
Dopo vari ricerche sono riuscito ad attivare l'autenticazione WS-Security sia sul webservice che sui clients che li chiamano... utilizzando microsoft.web.services3.

Ho scoperto che sul webservice in teoria basta aggiungere nel web config il seguente tag <replayDetection enabled="false" /> nella sezione <microsoft.web.services3> per disabilitare il nonce.
Quindi la sezione service3 risulterebbe così:
Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

Il mio problema adesso è lato client, dove mi sono accorto che al momento della chiamata soap viene aggiunti in modo automatico informazioni sul nonce (<wsse:Nonce>2PYwAe/pUdKloZbn5Hgw4Q==</wsse:Nonce> e <wsu:Created>2011-07-28T09:23:09Z</wsu:Created>):
Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

Come faccio a fare una chiamata ad un webservice senza passare il nonce?
Invece, altra domanda!, per disabilitare il nonce sul web service basta veramente aggiungere <replayDetection enabled="false" /> nel webconfig?

Vi ringrazio anticipatamente per qualsiasi aiuto riusciate a darmi:)

Alessio


Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5