Esecuzione report con vs 2010

mercoledì 11 aprile 2012 - 12.34
Tag Elenco Tags  C#  |  .NET 4.0  |  Windows Server 2008 R2  |  Visual Studio 2010  |  SQL Server 2008  |  Crystal Reports 2008

eddyG Profilo | Junior Member

Ciao a tutti!!!
Io ho il seguente problema:nella mia procedura,devo lanciare un report creato con crystal report...se nella versone 2008 mi bastava fare GLOBALS.ShowReport(NomeReport) ora nella nuova versione sono obbligatori altri valori...dopo il nome e il recordfilter mi viene chiesto di inserire una variabile di tipo Id "Filter id" se il filtro implementato è una query...ed in più mi vengono chiesti altri paramentri.
Qualcuno ha mai avuto a che fare con questa istruzione...dove posso trovare esempi che mi chiariscano le idee?

Grazie

freeteo Profilo | Guru

Ciao,
probabilmente hai usato un parametro dentro al report, ti basta passarglielo prima di visualizzarlo.
Ti conviene prendere spunto dagli esempi che ci sono qui:
http://gotreportviewer.com/
http://blogs.dotnethell.it/freeteo/SqlReporting-report-dinamici-con-gruppo-dinamico__15746.aspx
(anche se l'obbiettivo è diverso, gli viene passato un parametro e trovi il codice in allegato)

ps: per le prossime problematiche relative alle stampe, puoi postare in questa stanza: http://www.dotnethell.it/forum/Crystal-Reports.aspx

Ciao.

Matteo Raumer
[MCAD .net, MVP Visual C#]
http://blogs.dotnethell.it/freeteo
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5