Problema formula di selezione record con SAP Crystal Report

giovedì 14 giugno 2012 - 16.00
Tag Elenco Tags  VB.NET  |  .NET 3.5  |  .NET 4.0  |  Visual Studio 2010  |  Visual Studio 2008  |  Crystal Reports 10.0  |  Crystal Reports XI  |  Crystal Reports 2008

davideTal Profilo | Newbie

Salve,
ho appena convertito la mia applicazione da Visual studio 2008 a VS 2010 e per quanto riguarda i report da CR10 a SAP Crystal Report per VS2010.
Ho notato alcune differenze che per me sono problemi:
- non funzionano più le formule che sono state impostate nella selezione record (tasto destro sul report --> Report --> Formula di selezione --> record). Sospetto che non gradisca più le formule dove si devono valutare contenuti NULL.. C'è qualcuno che ha avuto lo stesso problema?
- Inoltre alcuni campi se non riescono a contenere la stringa viene visualizzato una serie di cancelletti (####). Si può disattivare questa "novità"?

Chiedo scusa se per caso esiste già una discussione simile..ho dato un'occhiata veloce al forum ma non ho trovato soluzione.
Grazie anticipatamente.

Saluti
Davide



********************************************************************
Se qualcuno fosse interessato, dopo vari tentativi ho scoperto che il problema delle formule sulla selezione record si presentava solo nell'anteprima di stampa tramite CristalReportViewer.
La soluzione che ho trovato è impostare sull'oggetto CrystalReportViewer la formula di selezione impostata nel report (oggetto ReportDocument):

crViewer.SelectionFormula = rptDoc.RecordSelectionFormula





Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5