CustomValidator

giovedì 20 dicembre 2012 - 19.09

zizu75 Profilo | Newbie

principiante disperato . Ho creato un una webForm con un controllo customValidator, nella pagina html ho inserito un piccolo script con JScript per la digitazione in una textbox di numeri pari,ora impostate tutte le proprietà ControlToValidate,ClientValidationFunction e ErrorMessage non funziona ,infatti se digito un numero dispari non succede nulla ,però se utilizzo lo stesso codice con visual studio 2005 tutto va per il meglio e il controllo funziona .Quando carico la pagina con IE ,sulla barra in basso esce un triangolino giallo con un punto interrogativo,clicco sopra e esce la seguente schermata
Dettagli errore pagina Web
Agente utente: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; FunWebProducts; SIMBAR={F2AA72FB-9520-4BD1-9E3A-264F7248C851}; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 2.0.50727; FunWebProducts; .NET4.0C)
Timestamp: Thu, 20 Dec 2012 18:05:00 UTC,
Messaggio: Errore di sintassi
Linea: 35
Carattere: 1
Codice: 0
URI: http://localhost/PrimoWebForm/ControlloValidazione.aspx


Messaggio: Previsto oggetto
Linea: 298
Carattere: 9
Codice: 0
URI: http://localhost/aspnet_client/system_web/1_1_4322/WebUIValidation.js

Sapete dirmi il perché?
P.S. Utilizzo visual studio 2003 con visual basic.net ,il browser Internet Explorer o Google Crome,

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5