Blocco SQL Server su Visual Studio Ultimate

giovedì 27 dicembre 2012 - 19.39
Tag Elenco Tags  VB.NET  |  SQL Server 2008 R2

86Marco Profilo | Expert

Salve a tutti ragazzi,
mi succede una cosa strana su Visual Studio Ultimate WinForms.

Sto creando una piccola applicazione con SQL Server e ho creato qualche procedura per l'inserimento e la selezione di dati.

La cosa strana che mi succede è questa:
Le procedure funzionano benissimo ma nel momento in cui creo nuove procedure per l'accesso ai dati e rieseguo il progetto lo stesso codice che prima funzionava va in blocca e mi compare l'errore seguente:

469x227 19Kb


Ma come è possibile? L'errore parla di connessione remota ma io SQL lo devo utilizzare da locale, come è possibile che prima tutto funziona e dopo qualche minuto lo stesso codice va in palla????

A qualcuno è capitato??
Sono bloccato non so che pesci prendere! Aitutatemi please :(

marco_grillo Profilo | Junior Member

L'errore è molto intuitivo, hai inserito male il percorso del server.

Posta la stringa di connessione

______________________________________________________________________________
Basta solo un carattere sbagliato nel codice sorgente per distruggere un'intera applicazione

86Marco Profilo | Expert

Ciao mi dispiace doverti contraddire ma come si spiega che prima il codice funzione e dopo lo stesso va in palla??? Non ho fatto alcuna modifica al codice!!

Ad ogni modo la connstring è questa Data Source=Server\SQLEXPRESS;Initial Catalog=Customers;User ID=xx;Password=xxxxxxx

ripeto: io lavoro in locale non in remoto...

marco_grillo Profilo | Junior Member

Ho capito benissimo il tuo problema ma forse facendo delle prove hai cancellato qualcosa. Prova con una connessione standard:

Server=myServerAddress;Database=myDataBase;User Id=myUsername;Password=myPassword;
______________________________________________________________________________
Basta solo un carattere sbagliato nel codice sorgente per distruggere un'intera applicazione

86Marco Profilo | Expert

Niente :(

ma prima funzionava ... ti assicuro che non ho cambiato nulla.

marco_grillo Profilo | Junior Member

Hai provato a fare un ping al localhost ?
______________________________________________________________________________
Basta solo un carattere sbagliato nel codice sorgente per distruggere un'intera applicazione

86Marco Profilo | Expert

Guarda cosa ho fatto:
ho aperto un nuovo progetto in Visaul Studio ed al load del primo form faccio connettere l'applicazione all' SQL server tramite la strnga di connessione che ho impostato nel primo progetto... e funziona!!!

E' come se il problema fosse nel progetto :( non nella connectionstring

marco_grillo Profilo | Junior Member

Prova a creare un nuovo progetto! Rispondi alla domanda del ping.

Poi non capisco una cosa... se la tua applicazione deve essere locale perchè hai scelto come db sql server ??


______________________________________________________________________________
Basta solo un carattere sbagliato nel codice sorgente per distruggere un'intera applicazione

86Marco Profilo | Expert

No non ho provato a fare il ping.... un progetto nuovo l'ho fatto e la connection string che nel primo progetto non funziona in quello nuovo invece si.

Utilizzo SQL express xche mi sta simpatico :)

marco_grillo Profilo | Junior Member

Mmm... strano! Comunque trasferisci tutto sul nuovo progetto e hai finito
______________________________________________________________________________
Basta solo un carattere sbagliato nel codice sorgente per distruggere un'intera applicazione
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5