Problema in fase di BUILT di una web application

venerdì 29 dicembre 2006 - 11.28

squilibrio Profilo | Expert

Ciao a tutti, in fase di debug non otteno nessun errore e la mia web
application viene eseguita correttamente, quando clicco su BUILT Web Site
ottengo alcuni errori di questo tipo:

Errore 1 The type 'ASP.NavBar' exists in both

'c:\WINDOWS\Microsoft.Net\Framework\v2.0.50727\Temporary ASP.NET
Files\app\2f3aaf84\1e2c4d72\App_Web_drgehxnr.dll'

and

'c:\WINDOWS\Microsoft.Net\Framework\v2.0.50727\Temporary ASP.NET
Files\app\2f3aaf84\1e2c4d72\App_Web_bske8zqd.dll'

C:\Documents and Settings\MY\Documenti\Visual Studio
2005\WebSites\app\UI\Master\DefaultBackOffice.master 14


Cosa sbaglio?


Grazie

freeteo Profilo | Guru

ciao,
come vedi quei file sono temporanei del framework che si è caricato in memoria per avere piu' velocita' di risposta a chiamate web.
Al momento non saprei se c'e' una procedura "ufficiale" per togliere sta cosa, pero' io tipicamente facevo :

- arrestavo ASP.net Development Server (o riavviavo il sito in IIS)
- tasto destro sopra alla soluzione->Clean Solution

e cosi' tutto andava di nuovo, perche' il runtime di asp.net (quindi alcuni assembly del framework) andavano a rigenerare tutti i componenti e quindi non avevo piu' problemi.
ciao.

Matteo Raumer
[MCAD .net]
http://blogs.dotnethell.it/freeteo

squilibrio Profilo | Expert

Grazie a tutti!
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5