Runtime Error

mercoledì 03 gennaio 2007 - 10.06

PSoftP Profilo | Newbie

Ho creato una piccola applicazione Ajax con VS2005, in locale funziona. Faccio l'upload sul server ftp della stessa applicazione e mi da questo runtime error

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

Per chi volesse vedere l'errore con i suoi occhi:
http://www.nuovaitalricambi.it/test/ajax/default.aspx

Grazie per l'aiuto.
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

alx_81 Profilo | Guru

Ciao!

>Ho creato una piccola applicazione Ajax con VS2005, in locale
>funziona. Faccio l'upload sul server ftp della stessa applicazione
>e mi da questo runtime error

prova a postare la parte del web.config sul customerror..
così vediamo come lo gestisci..
Se non hai toccato il web.config in quella sezione, controlla che il mode del CustomError sia a "Off"

>Grazie per l'aiuto.
>-----------------------------------
>doIt with dotNet!
>http://3mind.blog.kataweb.it/3mind
>

Alx81 =)

http://blogs.dotnethell.it/suxstellino

PSoftP Profilo | Newbie

Questo è il mio web.config

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

Che devo fare?

Siccome non sono molto pratico, potresti modificarmi tu l'intero codice che poi ricopro il mio web.config? Grazie
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Hai idea se sul server ci sono le librerie di ATLAS?
Andrea

PSoftP Profilo | Newbie

Non so se è questo il problema... per ogni tipo di applicazione web mi viene generato questo errore.
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Se le librerie che tu hai dichiarato nel web.config non esistono ti dará sempre lo stesso errore...
Anche se chiedi una pagina non presente (l'importante é che termini con .aspx).

Cmq se aggiungi la riga che ti suggerisce lui nel tuo web.config avrai un errore + dettagliato da far vedere...

Andrea

PSoftP Profilo | Newbie

potresti aiutarmi a modificare il web.config? L'ho allegato nel post precedente.
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Cerca il tag
<system.web>
e subito dopo inserisci questa riga
<customErrors mode="Off"/>
.

Faccio prima a scrivertelo che a modificare il codice...

OK?
Andrea
http://amelix.blogspot.com/index.html

PSoftP Profilo | Newbie

ho provato e mi da sempre lo stesso errore.
cancello il web.config e lo ricreo. inserisco il codice:

<?xml version="1.0"?> <configuration> <appSettings/> <connectionStrings/> <system.web> <compilation debug="false" /> <authentication mode="Windows" /> <customErrors mode="Off"/> <!--<customErrors mode="RemoteOnly" defaultRedirect="unauthorized.aspx"/>--> </system.web> </configuration>

Dovrebbe andar bene, invece stesso errore. se non mi aiutate voi non so proprio che fare...
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Prova a create una pagina aspx (usa il notepad) con questo codice:
<%@ Page Language="VB" %> <%@ Import Namespace="System.IO" %> <%@ Import Namespace="System" %> <%@ Import Namespace="System.Reflection" %> <script language="VB" runat="server"> Public Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Dim MyType As Type = Type.GetType("System.AppDomain") Label1.Text = MyType.Assembly.FullName.ToString End Sub </script> <form runat="server"> <asp:Label runat="server" id="Label1" /> </form>

Togli il web.config e dimmi che ti dice...

Questo script ti restituisce la versione ASP.NET che stà girando sul server. (Speriamo sia 2.0! )
Andrea
http://amelix.blogspot.com/index.html

PSoftP Profilo | Newbie

Strano... l'ho rinominato con un altro nome... ma il risultato è sempre quello... chissà dove lo vuole?
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Non è che c'è qualche altro web.config nelle cartelle + basse?
Andrea
http://amelix.blogspot.com/index.html

PSoftP Profilo | Newbie

nei figli o padri?
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Padri.
Il web.config viene ereditato partendo dal machine.config + tutti i web.config a salire.
Andrea
http://amelix.blogspot.com/index.html

PSoftP Profilo | Newbie

No, ho provato ma non c'è niente... non vorrei fossero impostazioni del server che mi ospita... non c'è un modo per indicare di utilizzare un diverso web.config?
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Tu riesci a mettere nella root questo file? (vedi allegato)
Andrea
http://amelix.blogspot.com/index.html

PSoftP Profilo | Newbie

l'ho inserito http://www.nuovaitalricambi.it/Version.aspx

non da risultati...
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Scusami!
Sono stordito!!!!!
Ti ho mandato il file prima di salvarlo....

Riscarica & uploda.

Cmq non ti ha dato errore!!!
Non è malissimo.
Andrea
http://amelix.blogspot.com/index.html

PSoftP Profilo | Newbie

La risposta è:
mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

MALE!
Hanno la versione 1!!!!

Quindi se utilizzi dotNet 2.0 sei a piedi...
Il file web.config non è compatibile con la ver 1 di dotNet e se l'è un po presa...

Chiudi l'aggiornamento alla versione 2...

Ciao e buona fortuna!
Andrea
http://amelix.blogspot.com/index.html

PSoftP Profilo | Newbie

Grazie. Proverò con altro... sigh! Ma sarà solo un problema per Ajax o per tutto ciò che sviluppo con VS2005?
-----------------------------------
doIt with dotNet!
http://3mind.blog.kataweb.it/3mind

amelix Profilo | Expert

Tutto lo sviluppo con VS2005....

Per il problema di AJAX si può "risolvere"... Ma la versione errata di dotNet è un grOOOsso problema

Andrea
http://amelix.blogspot.com/index.html
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5