Quegli errore che......

mercoledì 20 giugno 2007 - 07.37

bluland Profilo | Guru

Salve,

mentre codificavo e instanziavo dei metodi di una classe, in fase di debug la pagina mi ha dato il "noto" errore

Object reference not set to an instance of an object.

mi sono detto ok fammi capire dove ho sbagliato ed ho ripristinato allo stato precedente CRTL + Z, ma niente sempre lo stesso errore, alla fine mi sono ritrovato a ripristinare tutto allo stato 0, ma nonostante cio da sempre lo stesso errore!!!

si e' in qualche modo impallato il compilatore??

fortunatamente avevo una copia del file aspx e vb, ma se ritento la stessa operazione mi ritrovo punto ed a capo!!

idee voi che ne dite??


--------------------
Vincenzo PESANTE
System Engineer

alx_81 Profilo | Guru

>Salve,
>
>mentre codificavo e instanziavo dei metodi di una classe, in
>fase di debug la pagina mi ha dato il "noto" errore
>
>Object reference not set to an instance of an object.
>
>mi sono detto ok fammi capire dove ho sbagliato ed ho ripristinato
>allo stato precedente CRTL + Z, ma niente sempre lo stesso errore,
>alla fine mi sono ritrovato a ripristinare tutto allo stato 0,
>ma nonostante cio da sempre lo stesso errore!!!
>
>si e' in qualche modo impallato il compilatore??
>
>fortunatamente avevo una copia del file aspx e vb, ma se ritento
>la stessa operazione mi ritrovo punto ed a capo!!
>
>idee voi che ne dite??
Semplicemente nulla così proprio non mi è possibile dire nulla..
ci servirebbe quello che hai scritto.. almeno una porzione..
ti dice la riga dove genera l'errore?
Alcuni controlli fanno il bind invisibile se usi i controlli *datasource..
Hai rimosso qualche oggetto dall'aspx e sul vb è rimasto?
che versione di visual studio usi?
prova a postare qualche info in più per favore..
ciao!
Alx81 =)

http://blogs.dotnethell.it/suxstellino

bluland Profilo | Guru

Ora post un po' di codice ma fondamentalmente la mia perplessita' e' dovuta al fatto che anche se cancello la porzione di condice che genera l'errore che si trova in un button, e digito il button vuoto cmq mi da un errore segnalandomi una riga che non esiste niente.

ora prendo il codice e lo posto.
--------------------
Vincenzo PESANTE
System Engineer

bluland Profilo | Guru

ecco il codice:

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

il codice come lo vedi funziona mi da l'errore quando aggiungo un ulteriore parametro da passare che una ddl, e poi anche se ricancello l'aggiunta l'errore rimane sempre devo riscrivere la classe chiamante.


--------------------
Vincenzo PESANTE
System Engineer

alx_81 Profilo | Guru

>il codice come lo vedi funziona mi da l'errore quando aggiungo
>un ulteriore parametro da passare che una ddl
E' una DDL o un selectedvalue di una DDL?

>, e poi anche se
>ricancello l'aggiunta l'errore rimane sempre devo riscrivere
>la classe chiamante.
mmmmmmh... c'è qualcosa che non va in quello che fai..
sicuro di ricompilare per bene?
Alx81 =)

http://blogs.dotnethell.it/suxstellino

bluland Profilo | Guru

>>il codice come lo vedi funziona mi da l'errore quando aggiungo
>>un ulteriore parametro da passare che una ddl
>E' una DDL o un selectedvalue di una DDL?

si una drop down list
>
>>, e poi anche se
>>ricancello l'aggiunta l'errore rimane sempre devo riscrivere
>>la classe chiamante.
>mmmmmmh... c'è qualcosa che non va in quello che fai..
>sicuro di ricompilare per bene?
in che senso ricompilare bene? f5

>Alx81 =)

beh ho notato che se escludo dal progetto la classe che contiene la funzione non mi da + errore,, ho provato anche usando un modulo ma mi da sempre lo stesso errore
>
>http://blogs.dotnethell.it/suxstellino

--------------------
Vincenzo PESANTE
System Engineer

alx_81 Profilo | Guru

>>>il codice come lo vedi funziona mi da l'errore quando aggiungo
>>>un ulteriore parametro da passare che una ddl
>>E' una DDL o un selectedvalue di una DDL?
>
>si una drop down list
>>
>>>, e poi anche se
>>>ricancello l'aggiunta l'errore rimane sempre devo riscrivere
>>>la classe chiamante.
>>mmmmmmh... c'è qualcosa che non va in quello che fai..
>>sicuro di ricompilare per bene?
>in che senso ricompilare bene? f5
se fai Ctrl+SHIFT+B ricompili la solution..

>
>>Alx81 =)
>
>beh ho notato che se escludo dal progetto la classe che contiene
>la funzione non mi da + errore,, ho provato anche usando un modulo
>ma mi da sempre lo stesso errore
>>

proprio perchè non la compila se la escludi..
quindi l'errore sta sicuramente lì..
bisognerebbe vedere bene dove ti dà l'errore.. la riga che lo genera..
così non posso proprio esserti di aiuto..
>
>--------------------
>Vincenzo PESANTE
>System Engineer

Alx81 =)

http://blogs.dotnethell.it/suxstellino

bluland Profilo | Guru

si hai ragione continuavo a fare f5 invece del rebuild dell'intera soluzione, anche il mio compilatore si e' inceppato , forse ora posso valutare meglio il problema, anche se ho trovato un workaround che pero' rende la soluzione meno scalabile!!



--------------------
Vincenzo PESANTE
System Engineer

alx_81 Profilo | Guru

>si hai ragione continuavo a fare f5 invece del rebuild dell'intera
>soluzione, anche il mio compilatore si e' inceppato , forse
>ora posso valutare meglio il problema, anche se ho trovato un
>workaround che pero' rende la soluzione meno scalabile!!
racconta
>
>
>
>--------------------
>Vincenzo PESANTE
>System Engineer

Alx81 =)

http://blogs.dotnethell.it/suxstellino
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5