Per alex guru, se c'è ...

mercoledì 20 giugno 2007 - 11.15

tdj Profilo | Newbie

RISOLTO !

gridview + formview.
ho eliminato tutti i campi di edit dal formview, ho eliminato gli hyperlink edit e delete ed è rimasto solo l'hyperlink new.

funziona.

grazielostesso.

hey guru, non mi hai più filato.
ho visto che hai già risposto a qualcunaltro su gridview e detailsview per inserire records. ho anche io gridview e detailsview nella stessa pagina per inserire records in un db. come faccio però ad avere, in apertura pagina, i records esistenti visualizzati in gridview (è ok) MA i campi blank in detailsview per l'inserimento. io in detailsview vedo sempre il primo record e non so come "pulirlo".
chissà se mi sono spiegato ?

martinez Profilo | Senior Member

Ciao,

Credo che il guru non ti risponda semplicemente per la troppa banalità del problema ...
Io credo che un forum sia lo spunto per trarre stimoli all'apprendimento delle tecnologie trattate e non per ricevere "pappette" sempre pronte da dare in pasto alle nostre form senza nemmeno capire di cosa si tratti ...

Detto questo, mi scuso per lo sfogo, e ti passo la pappina ...

il controllo DetailView contiene una proprietà DefaultMode che viene usata per definire per l'appunto la modalità di startup del controllo tale proprietà può essere settata a ReadOnly (default) Edit ed Insert ... quindi per risolvere il tuo problema basta andare sulle proprietà del controllo e settare la proprietà ad Insert


Un saluto
Antonio

P.S. evita di inserire lo stesso post 300 volte per paicere. Grazie!

tdj Profilo | Newbie

bellissimo, simpatico, educato, intelligente, comprensivo, modesto. ce ne vorrebbe veramente tanta di gente così.

da adesso mi cancellerò da questo forum ma se non fosse possibile comunque non disturberò più cotali e cotante menti eccelse impegnate in problematiche per me incomprensibili.

alla faccia degli ambienti "open" e della modernità sopratutto dei giovani !

cordialità.

martinez Profilo | Senior Member

Non volevo offenderti e me ne scuso ... se ho provocato tale reazione ...

forse avrei fatto meglio ad ignorare il tuo messaggio ... scusami ancora ... ma in definitiva non ho fatto altro che:

1) dirti che se guardavi sulle proprietà del controllo non avresti scritto il post e magari saresti un bel pezzo avanti con la tua applicazione ... magari davanti ad un nuovo problema da risolvere

2) pregarti di non postare la stessa richiesta più di una volta ...

ancora scuse
Antonio

_J_ Profilo | Senior Member

Ciao,
forse non saranno affari miei ma, permettimi, ha un po' esagerato.
Non credo che la gente che si iscrive qua lo faccia per ricevere 'pappine', non c'è bisogno per forza si iscriversi su un forum per questo...
Credo più che altro che quello che serve a coloro che si iscrivono è un aiuto per poter imparare, specie per chi, come me , è nuovo del settore ed ha tanta voglia di imparare.

E poi ricorda che un inizio c'è sempre per tutti, anche per chi è più esperto. Infatti "nisciunu nasce 'mparatu" (nel mio dialetto 'nessuno nasce istruito').
Ti saluto amichevolmente

_J_
"Chi fa domande rischia di sembrare stupido,
chi non ne fa rischia di restare stupido..."

"Conosco me stesso? No, non parlo con gli estranei..."
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5