Problemi con hosting in Internet Explorer

venerdì 05 settembre 2003 - 14.13

dellui Profilo | Newbie

Salve a tutti,
ho sviluppato un mio custom control Windows.Forms che implementa un FormDesigner. Utilizzandolo in una applicazione Windows.Forms, funziona correttamente. Se cerco di usarlo in IE usando il tag OBJECT
(object ... classid="http:xxx.dll#namespace") non funziona.

La cosa è strana, perchè se uso una control library + semplice non ho problemi.

Andando a debaggare (che bello i neologismi! :)), ho visto che mi si blocca quando istanzio il mio DefaultDesignerHost.

La cosa è ancora + strana se considerate il fatto che esponendo il controllo come ActiveX e inserendolo alla vecchia maniera in IE (con il classid), la cosa funziona perfettamente!

Grazie a tutti,
dellui

Brainkiller Profilo | Guru

Ciao,
purtroppo non sono molto preparato in quest'area. L'unica cosa che posso fare e segnalarti alcuni riferimenti che credo ti possano essere utili:

http://msdn.microsoft.com/msdnmag/issues/02/01/UserCtrl/UserCtrl.asp
http://windowsforms.net/articles/iesourcing.aspx
http://www.devhood.com/tutorials/tutorial_details.aspx?tutorial_id=187

Fammi sapere se sono di tuo gradimento.
Ciao
David De Giacomi
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5