Visual Studio 2005, datasource ed errori impossibili

giovedì 26 luglio 2007 - 22.53

Carmine Profilo | Junior Member

Salve a tutti,
Da un pò sto provando ad usare Visual Studio 2005 e ASP.Net con un database
MySQL.
Ora... non so se la colpa è del MySql Connector .Net (uso la v. 5.1) o di
Visual Studio, o di entrambi.

Praticamente, fino a ieri tutto perfetto.
Oggi vado ad aggiungere un datasource, tutto ok, arrivo alla parte finale,
metto "test query" e:

"Parametro non corretto, l'indice (in base zero) deve essere maggiore o
uguale al numero degli argomenti".

Cioè... ma che significa???
Un giorno funziona e un giorno no...
Oltretutto, quando clicco su "aggiorna schema" nell' sqldatasource (infatti
non so come ma sembra non riuscire a recuperare lo schema, quindi ad esempio
se metto una FormView o un detailsview appare senza campi ed impossibile da
usare) mi da lo stesso errore.

Cosa posso fare? Qualcuno ha già avuto esperienze con ASP.Net + MySQL e
sopratutto riguardo i DataSource?

Il bello è che tralaltro ho fatto un altra pagina tempo fa, e però non dava quest'errore!
Cioè compare "a caso"... a volte funziona perfettamente il datasource e ora invece no... sto impazzendo...

Grazie a tutti in anticipo,

Webmaster di thetotalsite.it
Blog: blog.thetotalsite.it
La nuova community: forum.thetotalsite.it
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5