Asp.Net configuration

lunedì 17 settembre 2007 - 16.13

kueza Profilo | Newbie

Ciao ragazzi,

Ho bisogno di un aiuto, ho realizzato un sito web con l'autenticazione asp.net 2.0 quindi aprendo il sito d'amministrazione tramite visual studio
http://localhost:1570/asp.netwebadminfiles/default.aspx? riesco a inserire nuovi utenti, ruoli ed autorizzazioni.

Come faccio ad aprire il sito web di amministrazione su una macchina che non ha visualstudio installato??

Ciao e Grazie

gae58 Profilo | Senior Member

non ti so dire se ci sia qualche possibilità, personalmente ho creato varie webForm per settare utenti membership ed altro.

Vedi che ci sono oggetti predisposti a ciò.

ciao

Gaetano

kueza Profilo | Newbie

Grazie,
alla fine ho copiato la cartella webadminfile direttamente sul server dove mi serviva ed ho risolto.

rdxreg Profilo | Newbie

scusa, e come lo lanci il sistema di amministrazione???

grazie

kueza Profilo | Newbie

http://localhost/directoryvirtualedovehaicopiatoifileadmin/default.aspx?applicationPhysicalPath=C:\pathfisicotuawebapplication\&applicationUrl=/Directoryvirtualedelsitochevuoiamministrare

ciao

rdxreg Profilo | Newbie

ok, grazie, ci provo.
Quindi praticamente devo creare una virtual directory su IIS che punti a quella cartella dove copia i webadminfiles? giusto?

Grazie mille per l'aiuto. Ho sempre lavorato con l'autenticazione integrata perché le applicazioni che ho sviluppato sinora erano intranet, e ora invece mi trovo in questa gabola...

buona settimana

kueza Profilo | Newbie

giusto quando apri il sito ti chiederà username e psw basta che ti autentichi e avrai disponibile tutto.
Ciao

rdxreg Profilo | Newbie

ok! mille grazie per l'help

rdxreg Profilo | Newbie

sono riuscito a fare il tutto, ma ho ancora un problemino: vedo solo la cartella di partenza del mio sito, e non le sotto-cartelle in cui dovrei filtrare l'accesso. In più non riesco a quadrare alcune cose.
Ho creato un sitoweb sulla porta 800. Ho creato una virtual-directory e ci ho messo la mia applicazione. Ora, al di la di usare l'amministrazione per creare utenti, ruoli, assegnare accessi, ecc..., da quello che ne so l'accesso viene poi controllato da Asp.net leggendo le impostazioni del web.config.
Siccome tutta la mia applicazione deve essere protetta, io presuppongo che se nella cartella principale della mia applicazione ho una default.aspx ed una login.aspx, caricando l'applicazione dovrebbe leggere il web.config, e se c'è la negazione per ? e autorizzazione per un ruolo, dovrebbe chiedermi l'autenticazione tramite la login.aspx.
Però questo non succede e si accede alla applicazione in modo anonimo! C'è qualcosa che sto sbagliando secondo te? Su IIS c'è qualcosa da impostare?
grazie

rdxreg Profilo | Newbie

dimenticavo un dettaglio: per l'autenticazione non uso SQLExpress ma SQLServer2005 Professional. Non so se questo può implicare qualche problema.
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2024
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5