Anomalia del compilatore Visual Studio 2005 (allo stato uro della paro...

martedì 18 dicembre 2007 - 14.56

trinity Profilo | Guru

Ragazzi,
non so spiegarmela questa anomalia pertanto apro questo thread con la speranza che qualcuno mi possa aiutare.

Allora ho creato un progetto in visual basic 2005...
Salvo, aggiorno il codice tutto ok. Ovviamente oltre al codice aggiorno anche le parti grafiche delle form che sono proprio quelle che risalto all'occhio della persona appena si avvia il programma.
Compilo il file exe e lo lancio...A qusto punto magia ossia il file exe non mi si è aggiornato ossia è come se non venisse generato con le mie modifiche.
Ho provato ad eliminare il vecchio file (tenete presente che scrivo nella cartella originaria "nin" che mi propone il compilatore), ma niente.
Ho riavviato 3 volte il mio pc, scansionato con l'antivirus, defrag scandisk ma niente..Anzi vi dirò di + questa anomalia me la da da molto tempo a non solo su questo progetto anche su altri che ho eseguito.
In passato non ho mai paerto il thread perchè sapete come risolvevo?
Aprivo un nuovo progetto mi tenevo la soluzione bella nuova e gli importavo solo i file delle form e dei moduli e classi e tutto riprendeva la normalità finechè non mi riaccadeva questa anomalia.
Ma ora non ce la faccio + e sono ricorso con tante speranze al vostro aiuto.

Ciao


Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

Amodio Profilo | Expert

potrebbe essere dovuto a qualche impostazione dalla schermata di menu->opzioni
basta toccare qualcosa che si incasina il tutto
e visual studio ne ha fin troppe di opzioni pericolose

succede lo stesso su un'altro pc? se no, allora è una impostazione errata

potresti disinstallare, poi pulire il registro di eventuali voci sporche,in quanto potrebbero restare memorizzati impostazioni e settaggi, e infine reinstallare il tutto
questa opzione mettila come ultima speranza, la cosa opportuna è vedere di default, confrontando con un'altro pc quali settaggi ha di default per la compilazione e ripristinare tali settaggi


a proposito:
weila fabio ciao...come stai?

Stroke Profilo | Junior Member

sei sicuro ch venga ricompilato? Nell'OUTPUT non ti da errori di ricompilazione?

trinity Profilo | Guru

Rispondendo ad entrambi i post dico:

1 si mi succede anche su un altro computer
2 si l'exe viene compilato senza errori.

Tutto bene grazie e tu?
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

Amodio Profilo | Expert

sto pensando alla possibilità che tu potresti essere incappato nella scadenza del prodotto
si parla di questo qui
http://community.visual-basic.it/alessandro/archive/2005/12/19/16642.aspx
ovviamente è una supposizione
bisogna vedere i sintomi che da l'applicativo quali sono esattamente, in genere i prodotti M. danno un messaggio:"expired"





p.s.
ah tutto bene...ci si certifica, si studia, si lavora, ora sono alla TIM, ma spero di andare in australia

trinity Profilo | Guru

>sto pensando alla possibilità che tu potresti essere incappato
>nella scadenza del prodotto
>si parla di questo qui
>http://community.visual-basic.it/alessandro/archive/2005/12/19/16642.aspx

no tranquillo non mi è scaduto
>ovviamente è una supposizione
>bisogna vedere i sintomi che da l'applicativo quali sono esattamente,
>in genere i prodotti M. danno un messaggio:"expired"
>
>
>
>
>
>p.s.
>ah tutto bene...ci si certifica, si studia, si lavora, ora sono
>alla TIM, ma spero di andare in australia


ottimo, bravo quali certificazioni hai preso? io penso di prendere quelle per vb net l'anno prossimo ora sto troppo impicciato?
Ho realizzato dei progetti che mi stanno tenendo occupato.
Tu su cosa lavori sempre vb ed sql?

Ciao stammi bene
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

Amodio Profilo | Expert

ok allora ricapitoliamo:
non ti da erorri
non ti è scaduto

hai provato a vedere se hai qualche parametro..tipo la directory di dove deve creare l'eseguibile se è quella in cui poi vai a cercare?
facciamo una cosa...se hai ancora problemi posto una immagine di come ho io i settaggi, cosi' vediamo di confrontarli con i tuoi!!!

p.s.
ho 6 certificazioni, tra cui mpc, mcad,mcpd, come detto sopra sto progettando di andare in australia in quanto in italia la situazione anche se hai 5 lauree non è resea in ambito IT, le ditte cercano solo schiappe per pagarle poco :(
per puro OO lavoro alla TIM, nel settore analisi progetti

trinity Profilo | Guru

ottimo,
senti visto che hai già conseguito delle certificazioni,
quale è la certificazione per visual basic net?

e dopo posso fare gli esami?

hai qualche sito in italiano dove posso vedere le varie certificazioni e gli esami che vengono richiesti?

Ciao
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

Amodio Profilo | Expert

quelle che ho conseguito sono TUTTE per il framework
in italiano non esiste niente, puoi trovare solo qualche blog che ne parla in italiano
infatti l'esame è totalmente in inglese, come pure i libri

per visual studio hai risolto?

trinity Profilo | Guru

no non ho risolto resta ancora un vero enigma
Cirillo Fabio
www.wondernet.biz
fabio@wondernet.biz
http://blogs.dotnethell.it/fabiocirillo/
http://wnetsoftware.blogspot.com

Amodio Profilo | Expert

ok
domani ti uplodo un po di immagini
vediamo di confrontare le impostazioni

Amodio Profilo | Expert

tie
http://www.immobilzero.com/product/2.JPG
http://www.immobilzero.com/product/1.JPG

sono 2 immagini di impostazioni che dovresti avere di default, cambiando uno di questi parametri :
o non ti da errore
o ti compila in una directory diversa da quella che vuoi
o altro ancora....

the_follet Profilo | Newbie

Questa sera è successo anche a me...

Era un banalissimo progettino di test che aveva il solo scopo di provare un altro progetto di setup incluso nella solution.
Era abbandonato da qualche mese sul desktop e stasera l'ho aperto per fare alcuni esperimenti "al volo".

Tra le varie cose, ridimensiono un pulsante e premo F5. Le modifiche non vengono rilevate.
Controllo nella cartella Bin\Debug e l'exe risale a maggio scorso (mah...).
Allora provo a rigenerare il progetto. Stavolta quando lancio il debug le modifiche le prende, ma ogni volta devo rigenerare... (il file rigenerato viene ovviamente messo nella cartella Bin\Release, nella cartella Bin\Debug c'è sempre il file exe vecchio... ma allora perchè con F5 mi accetta le modifiche??? Questa cosa non ha assolutamente senso...).

Allora provo un'altra cosa: cancello il contenuto della cartella Debug, premo F5 e mi da errore in quanto la cartella di destinazione è vuota...

Mi sta venendo il dubbio che forse a creare tutto questo casino possa essere stata qualche impostazione sballata nel progetto di setup incluso nella solution.
E' possibile? Anche tu ne avevi uno?

Di sicuro il problema non è nella configurazione dell'editor di VS, perchè aprendo altri progetti (sia vecchi che recenti) tutto funzionava correttamente.
Per il resto, le proprietà del progetto sembravano settate regolarmente.

Non so, magari queste ulteriori info possono essere d'aiuto.
Saluti,
Luca
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5