WXP Pro ed errori interni 2908 e 2909

mercoledì 19 dicembre 2007 - 09.12

Raphus Profilo | Newbie

Salve a tutti,

è il mio primo post qui.
Ho un problema con un pc nuovo nuovo con WXP pro come SO.
E' una settimana che ce l'ho e l'ho passata a risistemare programmi e backup e quando pensavo che tutto filasse liscio è successo l pasticcio che vi descrivo:

1) Mentre installavo Open Office 2.3.1, l'installazione si è interrotta e sono continuate a comparire finestre con l'avviso "Errore Interno 2909" e poi "Errore interno 2908";
2) Siccome 'sti avvisi non accennavano a scomparire ho interrotto l'installazione dal Task Manager;
3) Ora in visualizzazione eventi compaiono decine di avvisi "OpenOffice 2.3 - Errore interno 2909 e 2908 - Origine MsiInstaller - msi.dll";
4) Ho provato a pulire il registro con CCleaner e a riavviare ma al riavvio del SO si visualizzano stranissime striature orizzontali variamente colorate, che denunciano chiaramente qualcosa di grave...

Non so davvero che pesci pigliare! Eppure in passato non avevo avuto nessun problema con OpenOffice. Secondo voi il problema è con Windows Installer 3.1 (KB893803), con Java (ho la Standard Edition 6 v. 1.6.0) oppure con .NET Framework (mi sono trovato installate tre versioni: la 1.1, la 2.0 e la 3.0)??? Con cosa è andato in conflitto OpenOffice??? Non sono uno smanettone e non ho testa di formattare e reinstallare tutto!

Help me, por favor!

MarKonE Profilo | Guru

Ciao, da un'occhiata a questo articolo :

http://support.microsoft.com/kb/555175/en-us

Prova a seguire i passi descritti nel "metodo 11". Vedi qualche voce relativa ad openoffice ?

Magari sbaglio ma punterei il dito su Windows Installer

Ciao!
My Blog... http://blogs.dotnethell.it/Mark/

Raphus Profilo | Newbie

Grazie Markone per le tue indicazioni. Solo due domande:

1) Perchè tra tanti metodi proprio l'11, l'unico che ha "warning" in premessa?
Ho già paura ad andare a toccare il registro con le mie manine!

2) A parte i messaggi di errore descritti, la cosa più inquietante che è capitata è che avviando o riavviando il pc (quando lo schermo è ancora nero e il SO si sta caricando) compaiono come dei segnali di interferenza, delle striature colorate che come curve di un grafico si spostano da dx a sx... è possibile che tutto ciò abbia a che vedere con l'installer?

Aspetto ancora un tuo parere e poi mi farò coraggio e proverò con il metodo 11...

Ciao

MarKonE Profilo | Guru

>Grazie Markone per le tue indicazioni. Solo due domande:
>
>1) Perchè tra tanti metodi proprio l'11, l'unico che ha "warning"
>in premessa?
>Ho già paura ad andare a toccare il registro con le mie manine!

Il warning appare sempre quando ci sono indicazioni per la modifica del registro. Se ti limiti a seguire le istruzioni non corri rischi di sorta. Al massimo verifca cosa vedi senza modificare nulla.

>2) A parte i messaggi di errore descritti, la cosa più inquietante
>che è capitata è che avviando o riavviando il pc (quando lo schermo
>è ancora nero e il SO si sta caricando) compaiono come dei segnali
>di interferenza, delle striature colorate che come curve di un
>grafico si spostano da dx a sx... è possibile che tutto ciò abbia
>a che vedere con l'installer?

Sembrerebbe più un' interferenza dovuta alla vicinanza di telefoni cordless, cellulari o qualche apparecchiatura simile.... è così ? A sistema acceso non si notano ?????

>Aspetto ancora un tuo parere e poi mi farò coraggio e proverò
>con il metodo 11...

>Ciao

Ciao!

My Blog... http://blogs.dotnethell.it/Mark/

Raphus Profilo | Newbie

Grazie, ci provo e ti faccio sapere l'esito.
Ciao

doda Profilo | Newbie

io avevo lo stesso problema fino a 10 minuti fa. ho lottato 3 giorni scaricando programmi di ogni tipo. ho risolto installando il microsoft framework v2.0.50727. cercalo sulla stalla e ci siamo capiti

Raphus Profilo | Newbie

Ciao Doda e grazie per il tuo intervento.
Il fatto è che io ho addirittura tre versioni (possono coesistere, lo dice Microsoft) del .NET Framework, 1.1, 2.0 e 3.0... Se, come dici, il problema stesse qui, allora dovrebbe trattarsi di una corruzione di queste librerie e la faccenda si complica... comunque, prima proverò a seguire il consiglio di Markone... come l'ho risolta o meno ve lo faccio sapere...

MarKonE Profilo | Guru

Il messaggio " Origine MsiInstaller - msi.dll " non mi fa pensare al framework.....anche perchè le 3 versioni convivono senza problemi.

Facci sapere come va...in qualche modo risolveremo


Ciao!
My Blog... http://blogs.dotnethell.it/Mark/

doda Profilo | Newbie

si ma anche io avevo il framework installato, però poi installando questa versione che ti ho mensionato sopra ho risolto

Raphus Profilo | Newbie

La versione delle framework che tu dici ce l'ho già installata, così come la v1.0.3705, la v1.1.4322 e la 3.0... tutti (anche Markone) dicono che possono assolutamente coesistere... solo non so perchè ho anche la v3.0 che è espressamente dedicata a Vista mentre io giro su XP... boh?

Raphus Profilo | Newbie

Ciao Markone,

nei due percorsi di registro indicati al metodo 11 della pagina di supporto Microsoft da te indicata non compaiono nè \InProgress nè \PendingFileRenameOperations...
Invece mi trovo riferimenti a chiavi di OO sul percorso HKCU, e precisamente le due seguenti cartelle: Software/OpenOffice.org/.../ShellNew e .../StartMenu
Poi, sotto HKCU/Software trovo un'altra cartella di OpenOffice che a sua volta ha al suo interno tre cartelle: OpenOffice.org, OpenOffice.org 2.3 e UNO... Boh?

Raphus Profilo | Newbie

Markone, ti confermo che:

1) le chiavi di registro indicate al metodo 11 non compaiono. Compaiono invece chiavi relative ad OpenOffice sotto HKCU;

2) le interferenze che compaiono sul monitor in avvio continuano ad esserci e non hanno a che fare con disturbi da cellulare o atri apparecchi... mi pare che sia qualcosa a livello di scheda video...

3) in Visualizza eventi tutti gli errori sono indicati così
Tipo evento: Errore
Origine evento: MsiInstaller
Categoria evento: Nessuno
ID evento: 10005
Data: 18/12/2007
Ora: 20.56.14
Utente: ***\AMMINISTRATORE
Computer: ***
Descrizione:
Prodotto: OpenOffice.org 2.3 -- Errore interno 2908. {3A377AC4-5D6A-4B3D-B312-C7096F1878B0}

Che faccio? Provo con il metodo 1, ossia ri-registrare Windows Installer? Comunque mi pare che le interferenze abbiano pocoa che fare con l'installer... è senz'altro un problema di scheda video... ma cosa può averlo generato?

Ciao, e grazie se continuate a darmi qualche dritta...

Raphus Profilo | Newbie

E se provassi con un bieco ripristino di configurazione alla prima data utile antecedente il verificarsi dell'errore? Secondo voi c'è la possibilità di risolvere qualcosa?
Ciao!

MarKonE Profilo | Guru

>E se provassi con un bieco ripristino di configurazione alla
>prima data utile antecedente il verificarsi dell'errore? Secondo
>voi c'è la possibilità di risolvere qualcosa

La possibilità c'è.

>Ciao!

Ciao!
My Blog... http://blogs.dotnethell.it/Mark/

Raphus Profilo | Newbie

Okkei, proverò con il ripristino, anche se non capirò mai che cosa è successo... Grazie e buone feste a tutti.
Ciao

Raphus Profilo | Newbie

Ciao Markone e Doda,

vi comunico che ho risolto solo uno dei due problemi descritti.
Infatti in avvio del SO continuo a visualizzare inquietanti interferenze, che però non si manifestano più a sistema avviato. Però mi pare di aver capito il problema relativo a Windows Installer. Infatti ho per caso trovato questo articolo che descrive proprio i sintomi che ho riscontrato cercando di installare Open Office: http://www.add-in-express.com/creating-addins-blog/2007/11/12/windows-installer-error-2908/

Si tratta semplicemente di eliminare una chiave di registro sbagliata che appare in questo percorso:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Installer\UserData\S-1-5-21-1123561945-1935655697-1060284298-1003\
Components\AD95649F068525549B26938D7D18FEA7
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5