Giapponese

venerdì 21 dicembre 2007 - 14.24

giowilla Profilo | Newbie

ciao a tutti, spero di postare nella sezione corretta,

ho un problema con la lingua giapponese per il watermarking di un'immagine
mi spiego: dalla pagina A tramite un form passo i parametri alla pagina B
tali parametri contengono:
- nome immagine
- scritta italiano
- scritta giapponese (scritta in katakana nel campo text)

nella pagina B ho realizzato uno script aspx che prende in pasto i tre parametri, crea l'immagine e imprime le due scritte
di watermarking. Per la scritta in caratteri occidentali nessun problema, per il giapponese solo rettangolini
nella stessa pagina B ho inserito un comune response.write (parametro_scritta_giapponese) che visualizza correttamente in katakana


ho provato anche a testare l'operazione utilizzando la funzione ChrW

Dim japaneseFont As New Font("Arial Unicode MS", 32)
japaneseText As New String(New Char() {ChrW(12292), ChrW(12449)})
gr.DrawString(japaneseText, japaneseFont, new SolidBrush(Color.Blue), 0, 80)

ma senza risultato

ho provato a passare il parametro della scritta giapponese con i caratteri codificati in unicode (es: グレト スパアク) ma anche così tutto bene nella scritta HTMl e solo cubetti nel watermarking

come mi posso muovere??
grazie a tutti
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5