Datagrid

giovedì 27 dicembre 2007 - 17.12

Piccione Profilo | Newbie

Ciao, vi scrivo per un problema che ho da alcuni giorni, ho un datagrid e un adodc, il tutto e semplice quando interrogo adodc, ma quando voglio riempire un datagrid da codice vado in panne, vi spiego, nel database ho un campo tipo che assume valori 1 e 2 voglio riempire il datagrid con i dati relativi al campo tipo 1 ecco cosa faccio
prima mi connetto al database
poi scrivo
sql="select from tabella_x where tipo=" & 1
form1.adodc1.recordsource=sql
potete tirarmi fuori da questo casino
grazie

StefanoLep Profilo | Senior Member

Per far funzionare adodc basta impostare queste 3 proprietà;

Adodc1.ConnectionString = "Stringa di connessione valida
Adodc1.RecordSource = "SELECT * FROM MiaTabella WHERE Campo = 1"
Adodc1.Refresh

Se hai anche un AdoDataGrid e la vuoi collegare per vedere il risultato ti basta impostare:

Set DataGrid1.DataSource = Adodc1

Volendo tutte queste impostazioni le puoi mettere a DesignTime, ma da codice è lo stesso.

E' la passione che genera il progresso :-)

Piccione Profilo | Newbie

Grazie, tutto ok

StefanoLep Profilo | Senior Member

>Grazie, tutto ok

Ciao, se le risposta è stata utile puoi cliccare su "Accetta la risposta" così chiudiamo il thread.
E' la passione che genera il progresso :-)
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5