Inserimento immagini in una tabella del DB

martedì 12 ottobre 2004 - 10.36

fra1979 Profilo | Newbie

Ciao a tutti .... ho un disperato bisogno di aiuto.

Devo creare un form per inviare dei dati ad un db access e nel form devo includere anche l'upload delle immagini in una tabella del database. Il tutto in un unico form!!
Come posso fare?

Vi do tutti i dati:

- Il DB si chiama "db2.mdb"
- La Tabella che deve ricevere i dati si chiama "Scheda"
- I Campi che compongono la tabella sono "Codice" (Autonumber), "Nome" "Cognome" "Indirizzo" "Hobby" "Eta" "Esperienze" "Commenti" "Email" "Telefono" "Fax" "Note" "Foto" (OLE OBJECT)

Vi ringrazio in anticipo!!!

fra1979 Profilo | Newbie

Ciao Coach. ...

mi dispiace ma per me è arabo .... sono un dilettante quindi avrei bisogno di essere guidato!!

Ti spiego quello che vorrei fare:
In pratica vorrei fare una pagina di immissione dati che invia tutti i record al DB (comprese le immagini) ed un'altra pagina di ricerca in cui inserisci ad esempio il cognome e ti viene una lista delle persono con quel cognome e cliccando sul cognome si apre la scheda completa di quella persona completa di foto

fra1979 Profilo | Newbie

Ciao!!

Allora questo è quello che sono riuscito a fare ..... ma appena provo ad inserire il codice di upload non funziona più niente

Come posso fare???
Grazie Ciaooo

<%
' FP_ASP ASP Automatically generated by a Frontpage Component. Do not Edit.

On Error Resume Next
Session("FP_OldCodePage") = Session.CodePage
Session("FP_OldLCID") = Session.LCID
Session.CodePage = 1252
Err.Clear

strErrorUrl = ""

If Request.ServerVariables("REQUEST_METHOD") = "POST" Then
If Request.Form("VTI-GROUP") = "0" Then
Err.Clear

Set fp_conn = Server.CreateObject("ADODB.Connection")
FP_DumpError strErrorUrl, "Cannot create connection"

Set fp_rs = Server.CreateObject("ADODB.Recordset")
FP_DumpError strErrorUrl, "Cannot create record set"

fp_conn.Open Application("Case_ConnectionString")
FP_DumpError strErrorUrl, "Cannot open database"

fp_rs.Open "Scheda", fp_conn, 1, 3, 2 ' adOpenKeySet, adLockOptimistic, adCmdTable
FP_DumpError strErrorUrl, "Cannot open record set"

fp_rs.AddNew
FP_DumpError strErrorUrl, "Cannot add new record set to the database"
Dim arFormFields0(2)
Dim arFormDBFields0(2)
Dim arFormValues0(2)

arFormFields0(0) = "Citta"
arFormDBFields0(0) = "Citta"
arFormValues0(0) = Request("Citta")
arFormFields0(1) = "Tipologia"
arFormDBFields0(1) = "Tipologia"
arFormValues0(1) = Request("Tipologia")

FP_SaveFormFields fp_rs, arFormFields0, arFormDBFields0

If Request.ServerVariables("HTTP_USER_AGENT") <> "" Then
FP_SaveFieldToDB fp_rs, Request.ServerVariables("HTTP_USER_AGENT"), "Browser_type"
End If
If Request.ServerVariables("REMOTE_HOST") <> "" Then
FP_SaveFieldToDB fp_rs, Request.ServerVariables("REMOTE_HOST"), "Remote_computer_name"
End If
FP_SaveFieldToDB fp_rs, Now, "Timestamp"
If Request.ServerVariables("REMOTE_USER") <> "" Then
FP_SaveFieldToDB fp_rs, Request.ServerVariables("REMOTE_USER"), "User_name"
End If

fp_rs.Update
FP_DumpError strErrorUrl, "Cannot update the database"

fp_rs.Close
fp_conn.Close

FP_FormConfirmation "text/html; charset=windows-1252",_
"Form Confirmation",_
"Thank you for submitting the following information:",_
"Immissione.asp",_
"Return to the form."

End If
End If

Session.CodePage = Session("FP_OldCodePage")
Session.LCID = Session("FP_OldLCID")

%>
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<meta name="GENERATOR" content="Microsoft FrontPage 5.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
</head>

<body>

<form method="POST" action="--WEBBOT-SELF--" enctype="multipart/form-data">
<!--webbot bot="SaveDatabase" suggestedext="asp" u-asp-include-url="_fpclass/fpdbform.inc" s-dataconnection="Case" s-recordsource="Scheda" u-database-url="mdb-database/fpdb/db2.mdb" s-builtin-fields="HTTP_USER_AGENT REMOTE_HOST Timestamp REMOTE_USER" s-builtin-dbfields="Browser_type Remote_computer_name Timestamp User_name" s-form-fields="Citta Tipologia" s-form-dbfields="Citta Tipologia" startspan --><input TYPE="hidden" NAME="VTI-GROUP" VALUE="0"><!--#include file="_fpclass/fpdbform.inc"--><!--webbot bot="SaveDatabase" endspan i-checksum="40548" --><p>
Case:<select size="1" name="Citta">
<option></option>
<option>Lucca</option>
<option>Altopascio</option>
<option>Bagni di Lucca</option>
<option>Barga</option>
<option>Borgo a Mozzano</option>
<option>Camaiore</option>
<option>Camporgiano</option>
<option>Capannori</option>
<option>Castelnuovo di Garfagnana</option>
<option>Coreglia Antelminelli</option>
<option>Forte dei Marmi</option>
<option>Fosciandora</option>
<option>Gallicano</option>
<option>Massarosa</option>
<option>Minucciano</option>
<option>Piazza al Serchio</option>
<option>Pietrasanta</option>
<option>Porcari</option>
<option>Seravezza</option>
<option>Sillano</option>
<option>Stazzema<

fra1979 Profilo | Newbie

Ciao!!

Sono riuscito a fare in modo che il db riceva i dati e li inserisca nelle tabelle corrispondenti .... ma tutto si blocca appena provo a inserire il codice per l'upload ... per fare in modo che l'immagine vada nel campo "Foto" della tabella "Scheda"

In allegato c'è il codice della pagina

Sapete dirmi come posso risolvere?
Grazie Ciaooo

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5