Problemi di avvio dei servizi di rete, workstation, server, spooler,.....

martedì 29 aprile 2008 - 18.24

mermer Profilo | Newbie

Gentili utenti del forum,
possiedo un windows 2003 che da ieri non ha più fatto partire i servizi accesso alla rete, server, workstation,... Con più antivirus ho pulito la macchina ma probabilmetne qualcosa nel file di registro è stato modificato perchè quando vado ad attivare i servizi che in "automatico" dovrebbero attivarsi esce un messaggio:
Errore 1068: Avvio del gruppo o del servizio di dipendenza non riuscito
Qualcuno può aiutarmi a far ripartire questi servizi
Grazie

Brainkiller Profilo | Guru

>Gentili utenti del forum,
>possiedo un windows 2003 che da ieri non ha più fatto partire
>i servizi accesso alla rete, server, workstation,... Con più
>antivirus ho pulito la macchina ma probabilmetne qualcosa nel
>file di registro è stato modificato perchè quando vado ad attivare
>i servizi che in "automatico" dovrebbero attivarsi esce un messaggio:
>Errore 1068: Avvio del gruppo o del servizio di dipendenza non
>riuscito

Eh eh probabile. Diversi servizi fondamentali di Windows sono dipendenti l'uno dall'atro. Se non parte uno a catena potrebbero non partire anche gli altri. Dovresti vedere la dipendenza tra i servizi e verificare qual è quello più in alto da cui dipendono tutti se si è avviato o meno.

Consiglio anche di verificare nell'Event Viewer alla ricerca di possibile cause e problemi.

Se certamente il server è stato infettato da virus ed è un server di produzione il consiglio è una bella piallata
Ciao

David De Giacomi | Microsoft MVP
http://blogs.dotnethell.it/david/

mermer Profilo | Newbie

Purtoppo non è partito nemmeno il servizio eventi per cui vien fuori un messaggio di errore

mermer Profilo | Newbie

ho troppe configurazioni da ripristinare per reinstallare tutto quanto.

Brainkiller Profilo | Guru

>ho troppe configurazioni da ripristinare per reinstallare tutto
>quanto.

Beh comunque non è che sei messo molto bene come situazione

Che configurazioni hai ? Perchè se hai sopra IIS puoi fare export e import del meta base ed è fatto. Se hai sopra anche se dubito Exchange, SQL Server, magari è un server di dominio o altro allora ti do ragione.
Ciao


David De Giacomi | Microsoft MVP
http://blogs.dotnethell.it/david/

lupotto Profilo | Newbie

Con che utente prova a partire il servizio rpc?

A me è capitato un problema simile al tuo su una macchina 2003 modificando l'utente di default di tale servizio e mettendolo come local system

Comunque prova ad avviare in provvisoria se riesci, e vedi se il server parte, poi butta un occhio all'event viewer e vedi dove hai errori, quasi sicuramente è qualche servizio che non riesce più ad avviarsi per un'errata configurazione o una sua alterazione e blocca tutto il resto.

Sempre a me con una macchina 2000, dopo l'installazione di alcune patch non partiva il servizio agent del gruppo di continuità, risultato: server che non saliva più e blue screen a profusione

Brainkiller Profilo | Guru

>A me è capitato un problema simile al tuo su una macchina 2003
>modificando l'utente di default di tale servizio e mettendolo
>come local system

Non ci avevo pensato, hai ragione però a proporre questa soluzione, forse perchè escludo a priori la possibilità di andare a toccare l'identity che esegue i servizi di sistema proprio per evitare mega-casini Già sono abbastanza quelli che capitano normalmente

Vediamo cosa dice mermer.
Ciao

David De Giacomi | Microsoft MVP
http://blogs.dotnethell.it/david/

lupotto Profilo | Newbie

La cosa strana tanto per dire è che sul 2000 l'rpc parte come "local system", sul 2003 come "network service", ora spostandolo da "network service" a "local system", a me il server iniziò ad avere problemi a profusione.

Un'altra cosa che mi è venuta in mente è che il server si potrebbe virtualizzare, vmware rilasciava una volta il p2v ora credo si chiami "vmware converter", così si clona la macchina e la virtualizza e fà tutti i test che vuole

Brainkiller Profilo | Guru

>La cosa strana tanto per dire è che sul 2000 l'rpc parte come
>"local system", sul 2003 come "network service", ora spostandolo
>da "network service" a "local system", a me il server iniziò
>ad avere problemi a profusione.

Beh il NETWORK_SERVICE l'hanno creato apposta perchè è meno potente di Local System e quindi nel caso di eventuali attacchi, l'attaccante può fare meno danni e ha meno accesso al sistema. E per fortuna che hanno cambiato approccio allo sviluppo dei software, secure by-design e by-default. Ora si cominciano a vedere i frutti.

David De Giacomi | Microsoft MVP
http://blogs.dotnethell.it/david/

lupotto Profilo | Newbie

>Beh il NETWORK_SERVICE l'hanno creato apposta perchè è meno potente di Local System >e quindi nel caso di eventuali attacchi, l'attaccante può fare meno danni e ha meno >accesso al sistema. E per fortuna che hanno cambiato approccio allo sviluppo dei >software, secure by-design e by-default. Ora si cominciano a vedere i frutti.

Vero c'è da dire che microsoft ha fatto parecchio lavoro per migliorare la sicurezza, come nel caso di molti servizi che non vengono installati di default come ad esempio il servizio "msdtc", però quello che dicevo io.....è che per assurdo a me l'rpc si incasinava girando con account "local system" che in teoria gode di privilegi più elevati dell'account network service

Brainkiller Profilo | Guru

>Vero c'è da dire che microsoft ha fatto parecchio lavoro per
>migliorare la sicurezza, come nel caso di molti servizi che non
>vengono installati di default come ad esempio il servizio "msdtc",

Vero, su Windows 2008 addirittura bisogna installare manualmente anche Outlook o AERO nel caso di AERO meglio perchè su un server non serve a niente.

>però quello che dicevo io.....è che per assurdo a me l'rpc si
>incasinava girando con account "local system" che in teoria gode
>di privilegi più elevati dell'account network service

Infatti, ma io sono arrivato al punto che non mi pongo neanche il quesito Lascio così come è uscito dalla casa senza toccare niente per ciò che riguarda i servizi di sistema sempre che non sia obbligato per particolari esigenze.

David De Giacomi | Microsoft MVP
http://blogs.dotnethell.it/david/

mermer Profilo | Newbie

Cari amici,
il problema era causato da un virus che aveva creato sotto c:\windows\debug\spool un programmino che installava un servizio "Local Spooler" e modificava le dipendenze dei servizi più critici da questo servizio.
Non partendo appunto "local spooler" non partivano Server, Workstation, Gestione eventi, FTP, SPooler, ecc...
Comunque grazie per le risposte

mermer

Brainkiller Profilo | Guru

>Cari amici,
>il problema era causato da un virus che aveva creato sotto

Ah ecco

>Non partendo appunto "local spooler" non partivano Server, Workstation,
>Gestione eventi, FTP, SPooler, ecc...
>Comunque grazie per le risposte

Io rinnovo il mio consiglio una bella piallata al server.
Oggi sono i servizi che non partono più, domani il registro, dopodomani qualcos'altro. Se è poi un server dove girano applicazioni critiche che devono avere un'alta disponibilità non puoi permetterti il rischio che per qualche motivo il server si blocchi. Magari mettere anche un buon antivirus in modo da ridurre la percentuale di rischio.

David De Giacomi | Microsoft MVP
http://blogs.dotnethell.it/david/

babbubba Profilo | Senior Member

... credo di avere lo stesso virus... non [ che ti ricordi il nome e se si puo risolvere con qualche stinger?
Babbubba
www.babbubba.net

Chiedere è curiosità ... rispondere è educazione.
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5