Null reference exception su oggetto esistente... [8o]

mercoledì 18 giugno 2008 - 16.09

pozzoli.samuele Profilo | Senior Member

Anzitutto ben ritrovati a tutti...

Aiuto!!! Non ne esco più.

Magari qualche buon'anima c'è cascato prima di me ed ha avuto un'intuizione geniale, ricolutiva del problema.

Facile, no... L'ho fatto MILIARDI di volte. Metto una tabella in una pagina, con la riga con l'intestazione. Leggo un db... Ed aggiungo le righe a seconda di quello che ho nel db.

Dunque. Funziona tutto alla perfezione, ovviamente, sul mio pc di sviluppo. Messo sul server aruba, fila tutto alla grande, finchè non deve inserire la riga nella tabella.

Creo le celle, metto il testo delle celle a seconda del contenuto delle tuple, metto le celle nella riga... tutto ok, fin'ora... Quando cerco di mettere la riga nella tabella, crash. Errore. Attenzione, solo sul server aruba. L'istruzione Tabella.rows.add(riga) mi da un null reference exception.

Ovviamente la riga è inizializzata. Ci ho pure aggiunto tutte le celle, quindi funziona. L'unica cosa che può non essere inizializzata è la tabella. Ma qui sta il barbatrucco! La tabella è messa giù a design time. E' compilata dentro la pagina. C'è... E' un oggetto della pagina!!!



Sigh sob!!! L'ho fatto milioni di volte anche all'interno dello stesso sito! Giuro, funziona! E qui no...

Nessuno ha un'idea, eh?

PS: Scusate il bipost, mi è andato in errore il primo inserimento!!!
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5