TCP error code 10061: No connection could be made because the target m...

giovedì 18 settembre 2008 - 09.46

Fabrizio70 Profilo | Newbie

Ho creato un nuovo WEB Site con VSS 2008, utilizzando un esempio semplice, semplice da MSDN. In pratica viene implementato un semplicissimo servizio con una banale ServiceContract.

Quando eseguo il tutto risco ad accedere alla pagina digitando su ie il seguente indirizzo:

http://localhost:34232/Service/Service.svc

Se invece provo a digitare il mio nome macchina al posto di localhost, prendo l'errore in oggetto e non risco a venirne fuori.

Tanto per cominciare, nel web.config, da nessuna parte trovo l'indicazione ne della porta (34232) ne della macchina (localhost); e poi non riesco a capire cosa mi blocca. Ho il Firewall di windows disattivo e nessun altro "intrigante" (o almeno credo) che mi blocca.

Cosa sbaglio? Datemi una mano, sono giorni che non riesco a fare un passo avanti...

Grazie

p.s. allego anche il web.config....

rossimarko Profilo | Guru

Ciao,

stai usando l'asp.net development server vero? In questo caso il problema è quello. Se hai IIS installato in locale prova ad usare quello e dovresti risolvere tutto.

-----------------------------------------
Rossi Marco
http://blogs.dotnethell.it/rossimarko

Fabrizio70 Profilo | Newbie

Aiuto!!! Cos'è l'ASP NET Developer? Io sono un programmatore di una certa esperienza in Windows, in architetture Client / Server anche complesse, ma sul WEB sono un bambino dell'asilo

Spiegamelo come se avessi due anni...

rossimarko Profilo | Guru

Quando fai partire un'applicazione web con visual studio sulla tray dovrebbe attivarsi una nuova icona. E' un piccolo web server che serve per provare i progetti web. Se ci passi sopra con il mouse vedrai che il nome è quello.

Se invece vuoi usare IIS come web server (e quindi usare anche la porta 80) allora devi modificare le proprietà di progetto hai la possibilità di scegliere quale web server usare.

Se hai creato un website devi prima andare su IIS e creare una virtual directory che punti alla cartella del tuo progetto e poi nelle proprietà del sito hai la voce "start options" --> Server --> Use custom server

Se invece hai creato un web project nelle proprietà hai la sezione "web" --> "Use IIS Web Server" con un pulsante che ti fa creare in automatico la virtual directory
-----------------------------------------
Rossi Marco
http://blogs.dotnethell.it/rossimarko

Fabrizio70 Profilo | Newbie

Scusami, ma sepolto dal lavoro non sono ancora riuscito a fare una prova come si deve.
Sicuramente io sono partito con un progetto web e infatti mi ha creato l'iconcina sulla tray assegnandomi una porta a suo piacimento; il problema è che dal device non navigo su quell'indirizzo in quanto il web è è stato creato come localhost e non sono riuscito a farli creare un web con il mio nome macchina (ma dove si setta? nel web config?)

Per IIS non ho ancora avuto il tempo di provare.

Comunque per quel poco che ho visto, non sono riuscito a il punto in cui fare questo:

>Se invece hai creato un web project nelle proprietà hai la sezione
>"web" --> "Use IIS Web Server" con un pulsante che ti fa creare
>in automatico la virtual directory

Tieni presente che sto usando 2008.

Grazie tante. Appeno ho risolto chiudo il post.

Fabrizio70 Profilo | Newbie

Sono riuscito a giocarci un pò...

Ho creato la Virtual Directory su IIS, lancio l'applicazione e mi restiruisce il seguente errore:

Unable to start debugging on the web server. The server do not support debugging for asp .net ecc...

Faccio un pò di ricerche e scopro che avendo installato IIS dopo VSS, non ho l'associazione .aspx -> DLL su
"Home Directory" -> Configuration.

Vorrei metterla, ma scopro di averla già per VSS 2005: c:\windows\microsoft.net\framework\v2.0.50727\aspnet_isapi.dll

ma la DLL aspnet_isapi.dll o simile per il framework 3.5 non esiste...

Hai qualche idea?

rossimarko Profilo | Guru

Ciao,

il framework 3.5 si basa comunque sul framework 2 quindi l'associazione corretta è quella. Per caso nelle proprietà del sito o della virtual directory hai una TAB ASP.Net? E' configurato correttamente con la versione 2.0?

Ti chiedo un'altra cosa.. che versione di IIS stai usando? Hai windows XP?

Una cosa che puoi fare è provare a reinstallare il supporto per iis con il tool aspnet_regiis: http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx

aspnet_regiis -i
-----------------------------------------
Rossi Marco
http://blogs.dotnethell.it/rossimarko

Fabrizio70 Profilo | Newbie

Grazie.

Finalmente ho risolto...

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5