Vs 2008 ha i prerequisiti con sql server 2008? compatibilità con sql s...

martedì 04 novembre 2008 - 23.20

ALomba Profilo | Newbie

Ciao a tutti, premetto che è la mia esperienza con sql server .
Ho sviluppato la mia applicazione windows in visual studio 2008 usando il db sql server 2008 e il framework 3.5, .
Ho creato poi il progetto di installazione, entro nella sezione "prerequisiti" e trovo solamente la versione di sql server sp2 oltre ai vari framework ecc...
Quindi, come devo fare x inserire sql server 2008 tra i prerequisiti?
C'è un modo per sviluppare in sql server 2008 e mantenere compatibilità con il 2005? Ho provato ad inserire come livello di compatibilità "sql server 2005", ma la mia applicazione, una volta installata, non si connette al database sulla macchina con il solo sql server 2005 installato..
Come ultima spiaggia mi sono riproposto di riscrivere il mio db in sql server 2005....ma spero vivamente ci siano soluzioni migliori...
Vi ringrazio anticipatamente per le eventuali risposte!

alx_81 Profilo | Guru

>Ciao a tutti, premetto che è la mia esperienza con sql server.
Ciao e benvenuto su DotNetHell!

>C'è un modo per sviluppare in sql server 2008 e mantenere compatibilità
>con il 2005? Ho provato ad inserire come livello di compatibilità
>"sql server 2005",
La connectionstring è la stessa. Connettersi ad un 2008 è la medesima cosa. Che errore ottieni? Perchè potrebbe essere che il db server non accetti le connessioni in rete.
Prova a postare l'errore. Perchè è sufficiente impostare la compatibilità per usarlo "come 2005".

>ma la mia applicazione, una volta installata,
>non si connette al database sulla macchina con il solo sql server
>2005 installato..
Cosa significa questa frase?

>Quindi, come devo fare x inserire sql server 2008 tra i prerequisiti?
Non so risponderti a questa domanda.

>Vi ringrazio anticipatamente per le eventuali risposte!
di nulla!

--

Alessandro Alpi | SQL Server MVP

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi
http://italy.mvps.org

ALomba Profilo | Newbie

L'errore che mi visualizza è quello dell'immagine... Come già detto, il DB è sviluppato in sql server 2008 e ho la necessità di avere compatibilità con sql server 2005....
Grazie!

lbenaglia Profilo | Guru

>L'errore che mi visualizza è quello dell'immagine... Come già
>detto, il DB è sviluppato in sql server 2008 e ho la necessità
>di avere compatibilità con sql server 2005....

Non è possibile eseguire l'attach/restore di un db su una versione precedente di SQL Server in quanto cambia il formato interno dei data files e del transaction log, quindi non puoi ottenere in alcun modo quello che chiedi.

>Grazie!
Prego.

Ciao!

--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/
http://italy.mvps.org

Earthquake Profilo | Junior Member

Ciao Io ho lo stesso problema come hai risolto?

lbenaglia Profilo | Guru

>Ciao Io ho lo stesso problema come hai risolto?
Se intendi eseguire l'attach/restore di un db 2008 su una istanza 2005 non è possibile e non esistono "trucchetti" per portare a termine l'operazione.
Puoi ricorrere a tooks di migrazione esterni o scriptare dati e metadati (in formato SQL Server 2005) per ricreare il db sulla istanza 2005.

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/

Earthquake Profilo | Junior Member

No intendevo l'aggiornamento dei prerequisiti visibili in VS2008 per SQLSERVER 2008 R2.

lbenaglia Profilo | Guru

>No intendevo l'aggiornamento dei prerequisiti visibili in VS2008
>per SQLSERVER 2008 R2.
Prova a chiedere nella stanza dedicata a VS.

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/

Earthquake Profilo | Junior Member

ok grazie!!
P.S.
Scusa ma qui non è il posto giusto ?
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5