Attiva Framework Applicazione NON Visibile

giovedì 07 maggio 2009 - 10.39

mars75e26 Profilo | Newbie

Ciao a tutti,
ho questo problema che non riesco a risolvere:
i pulsanti, le forms e i controlli del mio programma (aggiornato dal VB6 a VB2005) presentano una grafica non da XP.
Mi sono reso conto che da un momento all'altro in proprietà progetto è scomparso il checkbox "Attiva Frameword Applicazione" e non riesco a farlo riapparire.
Come posso fare?
Credo che il problema della grafica dei controlli dipenda proprio da questo.
Grazie a tutti.

Jeremy Profilo | Guru

Ciao Mariano.
Il fatto che tu non riesca a checkkare l'opzione Attiva Framework Applicazione è, probabilmente, dovuto al fatto che è presente una Sub Main ed è impostata come Avvio dell'applicazione ..... prova a commentarla od a scegliere una form di avvio, ricompila l'applicazione, e vedrai che tornerà disponibile.
In ogni caso, potresti risolvere lasciando tutto come è ed aggiungere nella Sub Main questo riga di codice:
EnableVisualStyles = true

Facci sapere...
Ciao

mars75e26 Profilo | Newbie

Ciao, Jeremy, e grazie per aver risposto con immediatezza.
Innanzitutto, non è presente alcuna Sub Main nel progetto; ad ogni modo, ho provato a crearmi una Sub Main e ad inserire la riga di codice "EnableVisualStyles = True",
tuttavia, mi dà il seguente errore "Nome "EnableVisualStyles" non dichiarato".
Ho anche provato a ricompilare il progetto ma niente.
Davvero non riesco a capire, anche perchè prima mi appariva la casella di controllo, adesso, invece, non c'è più niente e le opzioni nelle proprietà del progetto si fermano alle seguenti: "Nome Assembly", "Spazio dei nomi di primo livello", "Tipo di applicazione", "Icona", "Oggetto di avvio", "Informazioni assembly".
Il resto, se c'è, non è visibile.
Ancora un ringraziamento a tutti.

Grazie Jeremy, ho risolto!
Il problema era dovuto al fatto che il file Application.myapp, in formato XML, era stato salvato male dal linguaggio, con degli "00" in esadecimale fra ogni lettera; eliminato questo problema mi è bastato caricare fra i riferimenti "System.XML" prima non caricato. A questo punto, le opzioni di "Attiva Framework Applicazione" sono apparse e ho potuto ricompilare il progetto con la veste grafica che cercavo.
Grazie comunque a tutti.
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5