Reporting services problema parametro Multi Value

giovedì 10 settembre 2009 - 11.36

polliux77 Profilo | Newbie

Buongiorno a tutti,
sono veramente un neofita di reporting services eppure la mia azienda per necessità mi ha sbattuto a sistemare un progetto fatto da altri con tempi ridicoli...............
Vabbè non vi racconto nulla di nuovo .
Il mio problema è il seguente: ho alcuni report i quali hanno quasi tutti come parametri due campi data, e un parametro multivalue, alla prima apertura del report ho la lista multivalue correttamente popolata e con tutte le check box selezionate, senza modificare tale parametro agisco invece sui parametri data restringendo il range temporale di ricerca, alla modifica dei parametri data correttamente viene ricaricata la lista multivalue in quanto dipendente anch'essa dai parametri data, ovviamente avendo ristretto il range temporale mi trovo meno dati nell'elenco e come prima tutti comunque selezionati, il problema però si presenta ora, ovvero se io riallargo il range temporale e lo reimposto come prima questo fà si che la lista multivalue venga ricaricata ma sorpresona........... le check box non sono più tutte selezionate, ma sono selezionate solamente quelle che erano rimaste in lista al restringimento del range temporale.., ma chi glielo ha chiesto??? Io non ho toccato quei parametri non volevo li deselezionasse?
Come posso risolvere questa cosa.
Spero di essere stato abbastanza chiaro, vi ringrazio in anticipo del supporto ed a buon rendere, magari in altri campi però.....

dinoxet Profilo | Senior Member

salve,
intanto ci puoi postare un print screen della videata di RS prima del restringimento del range?
e poi cerchiamo di capire i parametri report a cosa sono legati.

DINOXET
__________________________________________
impossible is only a word

polliux77 Profilo | Newbie

Grazie innazitutto dell'interessamento,
Al passo1 puoi vedere il report alla sua prima apertura:


766x400 33Kb


Al passo2 subito dopo aver ristretto il range di data e non avendo eseguito nient'altro.


759x400 21Kb


Al passo3 praticamente non ho fatto nient'altro che reimpostare la data come era in principio et voila' le check box sono deselezionate.


774x400 23Kb


Spero di averti fornito tutte le info che ti occorrono.
Grazie ancora.
_________________________________________________________________________________________________________________

Agli stupidi non capita mai di pensare che il merito e la buona sorte sono strettamente correlati. [Johann Wolfgang Goethe]

dinoxet Profilo | Senior Member

mi fai una print screen del parametro linea?


DINOXET
__________________________________________
impossible is only a word

polliux77 Profilo | Newbie

Ok siccome ho edi dubbi su ciò che mi hai chiesto ti mando 3 screenshot spero in uno di questi di aver indovinato cosa volevi.
Il primo proviene dall'interfaccia web il parametro in questione è LineIds:


997x400 50Kb


Il secondo ed il terzo provengono dall'ambiente di sviluppo:


1016x616 97Kb



699x504 54Kb


Ti sono utili queste immagini, rispondono a ciò che mi hai chiesto?

Grazie
Agli stupidi non capita mai di pensare che il merito e la buona sorte sono strettamente correlati. [Johann Wolfgang Goethe]
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5