Caratteri sconosciuti in cr 9

mercoledì 23 marzo 2005 - 12.47

Icelele Profilo | Newbie

Ciao a tutti!
ho un problema che nn riesco a capire.....vi spiego la mia situazione:
- tramite un'applicazione asp.net richiamo crystal report 9 per fare una stampa....nn uso xò il crystal report viewer ma crea direttamente un .pdf
- una volta visualizzato il pdf, il mio utente manda in stampa il tutto...e...qui succede il patatrak!!!su una stampante funziona correttamente, cioè la stampa ha tutti i caratteri giusti....ma con un'altra stampante, della quale nn conosco nemmeno il modello, la stampa avviene ma tutto il testo in esso presente viene visualizzato, o meglio tramutato, in caratteri strani....per esempio lo "0" (zero) diventa ")" oppure il "5" diventa "+" e cosi via...anche per le lettere è la stessa cosa!!
Le immagini sono giuste! e la cosa + strana è che stampo tutto in "verdana" o "times new roman" e qst son i caratteri che nn vengono visualizzati correttamente......ma ho una serie di caratteri in "webdings" che vengono stampati tutti correttamente!!!
X favore aiutatemi xchè nn ho idea di cosa fare!!!
Grazie mille e buona giornata a tutti!!
Lele

Andy Profilo | Senior Member

Due domande..la stampante con cui stampi i tuoi report è la predefinita?
Hai provato a resinstallare l'ultimo driver della casa madre della stampante?

Icelele Profilo | Newbie

prima di tutto grazie x avermi risp! ;-)
allora t spiego meglio....la stampante nn è mia...è di un cliente che sta circa a 4ore di auto da dove sono io.....nn so se sia la stampante predefinita...e x qnt riguarda i driver...nn penso che li abbia aggiornati...il fatto è che anche lui ha provato a stampare su altre stampanti che ha e li la stampa risulta perfetta...solo su qst laser da problemi e lui dice che è di sicuro qlc che ho sbagliato io xchè altre stampe le ha sempre stampate....e io che gli dico?!?io ho provato a cercare e l'unica cosa che ho trovato è potrebbero essere i font della stampante che nn sono aggiornati...xò nn so....tu sai qlc di +?
Grazie ancora e buona giornata

Andy Profilo | Senior Member

Ciao..te l'ho chiesto perchè ho notato che CR(o almeno quello in versione limitata, allegato a VS.net) imposta la creazione del report sui parametri (dimensioni, caratteri, etc..) della stampante predefinita sul Pc in cui viene lanciato; così se tu stampi su una stampante che non è predefinita rischi di aver creato il report su parametri di un'altra stampante, e questo potrebbe essere un problema.

Fagli comunque aggiornare i driver, (tanto ha solo da guadagnarci), e..una consolazione..se il report risulta perfetto su altre stampanti(che il tuo cliente ha provato) allora è un segno che ciò che non va non è la tua programmazione, ma l'utilizzo su quella specifica stampante..

Icelele Profilo | Newbie

ok...grazie mille!il fatto è che è uno di quei clienti pesanti che t danno sempre la colpa di tutto.... ;-))
Vabbè cercherò di farglielo capire...e sxiamo che funzioni...
;-))
Grazie ancora, buona giornata e buona pasqua!
Lele

daniela80 Profilo | Newbie

Ciao,

anch'io ho avuto il tuo problema con le stampe...mi chiedevo se poi hai risolto.
Potresti in tal caso dirmi cosa hai fatto!!
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5