Resx Giapponese ja-JP

lunedì 14 dicembre 2009 - 14.06

enzo49910100 Profilo | Junior Member

Ciao a tutti spero che qualcuno possa darmi una mano stò realizzando
un'applicazione multilingua in asp.net 1.1 però non riesco a visualizzare i caratteri giapponesi, le altre lingue funzionano tutte,
qualcuno ha un idea che potrebbe aiutarmi
grazie

Brainkiller Profilo | Guru

>Ciao a tutti spero che qualcuno possa darmi una mano stò realizzando
>un'applicazione multilingua in asp.net 1.1 però non riesco a
>visualizzare i caratteri giapponesi, le altre lingue funzionano
>tutte,qualcuno ha un idea che potrebbe aiutarmi

Hai impostato l'encoding via web.config in UTF-8 / Unicode ?
I caratteri inseriti nel file .resx li vedi correttamente ? Però non li vedi correttamente rappresentati nella pagina ?
Ciao

David De Giacomi | <empty>
http://blogs.dotnethell.it/david/

enzo49910100 Profilo | Junior Member

ho risolto la visualizzazione nel browser con l'installazione di un package di windows ie_ja.exe ma adesso
ho un altro problema non mi si visualizzano in maniara corretta i caratteri giapponesi nel file di risorse .resx di visual studio
sai come posso risolvere il problema
grazie

Brainkiller Profilo | Guru

>ho risolto la visualizzazione nel browser con l'installazione
>di un package di windows ie_ja.exe ma adesso
>ho un altro problema non mi si visualizzano in maniara corretta
>i caratteri giapponesi nel file di risorse .resx di visual studio

Eh si, il browser potrebbe avere la necessità di installare caratteri aggiuntivi per visualizzarli correttamente.
Se non ricordo male anche da Windows bisogna fare questa operazione. Prova ad andare nel panello di controllo, impostazioni regionali / regional settings, e vedi lì dentro quando ti appare una finestra di questo tipo:
http://www.west-wind.com/weblog/images/11/o_Regional.png

Però mi sembra strano. Io lavoro su Windows 7 e Vista con Visual Studio 2008 e vedo correttamente i caratteri nei .resx senza installare niente.
Ciao

David De Giacomi | <empty>
http://blogs.dotnethell.it/david/

enzo49910100 Profilo | Junior Member

ma devono essere checcati gli elementi dell'immagine che mi hai inviato?

Brainkiller Profilo | Guru

>ma devono essere checcati gli elementi dell'immagine che mi hai
>inviato?

Aspetta, volevo capire che Visual Studio utilizzavi prima e che OS ?
E inoltre cosa vedi al posto dei caratteri, magari se puoi allega una screenshot.
Ciao

David De Giacomi | <empty>
http://blogs.dotnethell.it/david/

enzo49910100 Profilo | Junior Member

uso visual studio 2003 framework 1.1 e windows xp al posto dei caratteri giapponesi vedo dei quadratini

Brainkiller Profilo | Guru

>uso visual studio 2003 framework 1.1 e windows xp al posto dei
>caratteri giapponesi vedo dei quadratini

Se copi e incolli invece i caratteri giapponesi nel codice li vedi oppure vedi quadratini anche lì ?
Prova a selezionare il file di risorse, poi menù File -> Salva con nome. Quando ti si apre la finestra di salva a fianco del bottone salva c'è un triangolino in basso escono due opzioni una delle due è salva con encoding. Vedi che encoding è selezionato.
Io ho Unicode (UTF-8 with signature) - Codepage 65001
Prova a selezionarlo anche tu e dai ok.
Dopo prova a re-incollare i caratteri dentro il file di risorse.
Ciao

David De Giacomi | <empty>
http://blogs.dotnethell.it/david/
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5