[.NET] Sequenza di installazione Framework .NET

martedì 11 maggio 2010 - 11.09

omniteo790 Profilo | Newbie

Ciao.
Ho un Pc con il framework .net 2.0 installato. Ho realizzato un'applicazione che necessita del framework 3.5 installato. Volevo sapere se posso installare direttamente il framework .net 3.5 sp1 oppure devo realizzare la seguente sequenza:


* Service Pack 2.0
* .net 3.0
* Service Pack 3.0
* .net 3.5
* .net 3.5 sp1
* hotfix 3.5 sp1



Grazie

kataklisma Profilo | Senior Member

>Ciao.
Ciao!

>Ho un Pc con il framework .net 2.0 installato. Ho realizzato
>un'applicazione che necessita del framework 3.5 installato. Volevo
>sapere se posso installare direttamente il framework .net 3.5
>sp1 oppure devo realizzare la seguente sequenza:
>
>
> * Service Pack 2.0
> * .net 3.0
> * Service Pack 3.0
> * .net 3.5
> * .net 3.5 sp1
> * hotfix 3.5 sp1

Esatto, devi installare i framework in quella sequenza se vuoi una piena compatibilità. :)
>Grazie
Di niente, buona giornata!

------------------------------------------
Ignazio Catanzaro

http://blogs.dotnethell.it/swdev/

omniteo790 Profilo | Newbie

Grazie mille.
Perchè ho letto da alcune parti che bastava il 3.5 sp1.

Comunque per test ho provato ad installare il 3.5 sp1 direttamente e ho notato che mi ha installato anche la versione 3.0.
A quali problemi potrei andare incontro?
Però ora farò come mi dici tu, disinstallo e rifaccio.

Ho due alteriori domande:
* Ho notato che la versione .3.5 sp1 non dovrebbe essere solo il SP ma la versione completa con integrato il SP. Sbaglio? (Posso quindi tralasciare la 3.5)
* Devo installa anche la 2.0 e i suoi sp1 e sp2 o posso saltare alla 3.0 diretto?

jchnusa Profilo | Junior Member


>Comunque per test ho provato ad installare il 3.5 sp1 direttamente
>e ho notato che mi ha installato anche la versione 3.0.
>A quali problemi potrei andare incontro?
>Però ora farò come mi dici tu, disinstallo e rifaccio.
>
>Ho due alteriori domande:
>* Ho notato che la versione .3.5 sp1 non dovrebbe essere solo
>il SP ma la versione completa con integrato il SP. Sbaglio? (Posso
>quindi tralasciare la 3.5)
>* Devo installa anche la 2.0 e i suoi sp1 e sp2 o posso saltare
>alla 3.0 diretto?

stavo proprio scrivendoti la risposta alla prima donmanda e mi hai fatto venire il dubbio. Si la 3.5 sp1 è uscita prima del 3.5
E' stata apportata qualche modifica prima del suo rilascio... ma anche la 3.0 mi pare abbia la stessa storia ..anzi...a maggior ragione si chiama 3.5 e non 3.0 sp1 perkè è la stessa 3.0 chiamata 3.5 perchè non sarebbe stato normale un salto dalla 2.0 alla 4.0 e quindi la 3.5 è una come se fosse una 3.0.
scusa il casino nelle mie parole comunque ho letto qualche cosa da qualche parte che diceva questo. forse nel libro di Daniele Bochicchio asp.net 3.5 per tutti. ti darò conferma. Ciao
----Studio ASP.NET 3.5 - Visual Web Developer 2008 - VB ...ed ogni tanto bevo una birretta :D ( il tutto per passione )----

jchnusa Profilo | Junior Member

Riporto qui alcune righe del paragrafo " Architettura del .NET Framework 3.5" del libro di Daniele Bochicchio

Diversamente da quanto successo in passato per le relase 1.1 e 2.0, il .NET framework 3.5 nasce non tanto come una nuova versione completa, bensì come un aggiornamento incrementale delle precedenti versioni. Il .NET Framework 3.5 include infatti sia il .NET 2.0 che il .NET 3.0, nonchè i relativi SP rilasciati dal 2005 ad oggi.

Non trovo nulla da asssociare alle mie affermazioni dellla prima risposta il che mi fa pensare di averti detto cose fasulle ( non so perkè ma ne ero convinto ) Ciao
----Studio ASP.NET 3.5 - Visual Web Developer 2008 - VB ...ed ogni tanto bevo una birretta :D ( il tutto per passione )----

kataklisma Profilo | Senior Member

>Grazie mille.
>Perchè ho letto da alcune parti che bastava il 3.5 sp1.

Si la 3.5 sp1 include le versioni precendenti, diciamo che potresti optare per questa sequenza:

Framework 3.5 sp1,
Framework 4.0 (se ti serve),

Comunque sia, le versioni 1.1 2.0 e 3.0 sono installate di default sui S.O Win7 e puoi tranquillamente lasciarle ;)

Io per abitudine e vicissitudini passate le installo tutte...ma potresti evitare con la versione 3.5 sp1 ;)

Ah p.s la 1.1 non è inclusa in nessuna installazione e dovresti installarla a parte....decidi tu se seguire il mio consiglio o meno ;)
Ciao!
------------------------------------------
Ignazio Catanzaro

http://blogs.dotnethell.it/swdev/

omniteo790 Profilo | Newbie

Ok..
Allora visto che ho la .net 2.0 (e 1.1) già installata installerò solamente la 3.5 sp1 e poi l'hotfix consigliato sul pagina di download.
Se avrò problemi vi farò sapere.
Grazie

kataklisma Profilo | Senior Member

>Ok..
>Allora visto che ho la .net 2.0 (e 1.1) già installata installerò
>solamente la 3.5 sp1 e poi l'hotfix consigliato sul pagina di
>download.
Perfetto!

>Se avrò problemi vi farò sapere.
Non avrai nessun problema ;) buon coding!

Ciao!

>Grazie
Di niente!

------------------------------------------
Ignazio Catanzaro

http://blogs.dotnethell.it/swdev/
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5