Valori campo parametro dinamico diversi da quelli presenti nel db

mercoledì 14 luglio 2010 - 13.48

fasti Profilo | Newbie

Ciao a tutti,
espongo brevemente il problema
1) nel db ho un campo "anno" di tipo stringa che ha 6 valori: 2004, 2005, 2006, 2007, 2008, 2009.

331x173 11Kb

2)ho creato un campo parametro dinamico che servirà a confrontare quanto inserito dall'utente con il campo "anno".

254x419 22Kb

Problema: quando viene visualizzato il campo parmetro i valori della tendina non sono tutti quelli presenti nel db ma solo 4 (2004, 2005, 2006, 2007)

N.B.
Il report funnziona correttamente quando non utilizzo i parametri.
Qundo utilizzo il parametro, per i valori presenti in tendina i confronti vengono effettuati correttamente.

Grazie mille per la disponibilità


freeteo Profilo | Guru

Ciao,
potrebbe essere un problema di cache? Guarda nelle opzioni del report se è fleggato "Save Data With Report" oppure qualcos'altro di relativo a questa possibilità di limite di dati...

Ciao.

Matteo Raumer
[MCAD .net, MVP Visual C#]
http://blogs.dotnethell.it/freeteo

fasti Profilo | Newbie

Ciao Matteo,
così come mi hai suggerito ho spuntato il flag, ma non credo che il problema sia relativo alla cache, perchè già dalla prima inzializzazione del campo dinamico, infatti l'elenco dei valori non era correttamente valotrizzato sin dalla prima creazione del parametro.

Grazie
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5