Problema con un report

sabato 28 agosto 2010 - 20.02
Tag Elenco Tags  VB.NET  |  .NET 3.5  |  Windows XP  |  Visual Studio 2008  |  Access (.mdb)  |  Crystal Reports 2008

sonnicolo Profilo | Newbie

Ciao a tutti, nella mia applicazione devo stampare una ricevuta con lo schema in allegato. Ho deciso di utilizzare crystal report per poter stampare agevolmente (o quasi).
Vi spiego nello specifico cos'ho fatto in quanto quando lancio il report i dati che vi trovo dentro non sono quelli che mi aspetto.

Dal Report Designer mi costruisco lo schema del mio report trascinando i campi di database all'interno del report. Da VisualStudio recupero i dati che intendo passare al report e li metto in un dataset che passo tramite la SetDataSource all'oggetto Report. Il dataset contiene i dati che mi servono.

Quando lancio il report i dati sono diversi, sembra quasi che se ne freghi del dataset che gli ho passato.

ecco il codice che utilizzo nella load del form:

Dim DB As New Data() 'classe per accesso DB
Dim MyDataset As New DataSet()
MyDataset = DB.ReportRimborso(1, 3, #8/16/2010#, #11/2/2010#) ' chiamata alla funzione che mi recupera i dati di cui vorrei il report
Dim MyReport As New Ricevuta 'oggetto crystalreport .rpt

MyReport.SetDataSource(MyDataset)
CrystalReportViewer1.ReportSource = MyReport

Qual'è la procedura corretta per effettuare queste operazioni? Devo usare i parametri?


300x400 5Kb

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5