Datagrid vuoto

giovedì 22 settembre 2005 - 16.33

dgpweb Profilo | Newbie

Ciao a tutti. Sono nuovo della piattaforma e devo connettermi ad Oracle utilizzando i dataset. Ho seguito la guita che ho trovato su questo sito e devo dire che è molto semplice da seguire e da capire. Ho creato un dataAdapter con una nuova connessione al Provide Microsoft Ole DB Provider For Oracle configurandolo corrattamente (il teste della connessione è ok). Ho generato il DataSet dal dataAdapter e ho inserito un dataGrid in binding con il dataSet generato. Nel page load del form ho riempito (fil) il dataAdapter con la tabella del dataset. Mando in esecuzione l'applicazione aspx ma il risultato è il nulla, cioè la pagina è tutta bianca e se vedo l'html mi rendo conto che dal dataGrid non è stato creato nulla.
Ho provato anche a fare la preview del dataAdapter e ottengo i risultati sperati.
Sapresti dirmi in cosa sbaglio?

Brainkiller Profilo | Guru

Ciao,
ti sei ricordato di chiamare il metodo DataBind() della DataGrid ?
Ti riporto l'ordine delle chiamate

SqlConnection o OracleConnection
SqlDataAdapter o OracleDataAdapter
chiamare metodo Fill riempiendo un DataSet ds
assegnare alla proprietà DataSource della DataGrid il Dataset
chiamare il metodo DataGrid

secondo me manca quello.
Ciao

David De Giacomi
Microsoft MVP
http://blogs.dotnethell.it/david/

dgpweb Profilo | Newbie

E' vero, mancava quello. Mi ha tratto in inganno il fatto che sull'esempio non c'è scritta questa istruzione..
Cmq GRAZIE!

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5