Stampa crystal report

venerdì 11 novembre 2005 - 17.18

bruce Profilo | Newbie

ciao a tutti!

Io ho il seguente problema:

sviluppando un software comprensivo di odbcdataadapter e relativi dataset mi trovo ora nel punto in cui voglio stampare,utilizzando adobe il report creato.

Nel report è presente anche un sottoreport.

il mio problema è questo:se visualizzo in un foglio di adobe un record nel quale non è stato riempito il dataset relativo al sottoreport,non mi visualizza nemmeno il resto dei dati e per tanto viene aperto un PDF vuoto.

Come posso fare per ovviare a questo?

ringrazio anticipatamente per l'aiuto

freeteo Profilo | Guru

ciao,
direi comportamento anomalo.
Hai provato a sopprimere la sezione del sottoreport e stampare ti escono i dati del report principale?
se si:
allora andiamo a fondo sui legami che hai messo tra report principale e sottoreport....

se no:
se visualizzi il report invece di esportarlo direttamente in pdf funziona correttamente?

aspetto notizie :-)
ciao

Matteo Raumer
.net addicted :-)
http://blogs.dotnethell.it/freeteo

bruce Profilo | Newbie

Ciao

Ho provato,come da tuo suggerimento ad eliminare il corpo del sottoreport dal report principale.
A questo punto il report viene riempito nel modo corretto in tutte le sue parti per quanto riguarda i dati principali.

Ti ringrazio per il tuo interessamento.

Bruno

bruce Profilo | Newbie

Sono riuscito a risolvere il problema,Era una stupidata:

all'ìinterno del crystal report interno a Visual,ad un certo punto,arrivi alla schermata che ti visualizza il collegamento creato tra le tabelle utilizzate.
Bene,il problema era dato proprio da questo collegamento e,eliminandolo,ho risolto tutto ed ora funziona a meraviglia.

Grazie ancora per il tuo appoggio.

Eventualmente se ho altri problemi,spero vivamente non sia cosi,so dove posso appoggiarmi per poterli risolvere.

Grazie

Ciao

Bruno

freeteo Profilo | Guru

ciao Bruno,
ottimo che fosse 1a stupidata :-)
cmq io ti sconsiglio di legare le tabelle dentro al report se non necessariamente e per pochi dati, perche il link di crstal è 1po lento e a volte nn precisissimo, fai meglio a lavorare con le left join di sql e passare gia' i dati "linkati".
Per quanto riguarda i link dei sottoreport invece no nho mai avuto problemi in merito, funzionano bene...:-)

ciao

Matteo Raumer
.net addicted :-)
http://blogs.dotnethell.it/freeteo
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5