Mysql

venerdì 25 novembre 2005 - 10.29

Gemini Profilo | Expert

Ciao a tutti
Hoil seguente problema. Quando accedo al mio db mysql(versione 5) ricevo il seguente messaggio:
'Client does not support authentication protocol requested by server; consider upgrading MySQL client'
Ho provato a cambiare la password:
mysql> UPDATE mysql.user SET Password = OLD_PASSWORD('newpwd')
-> WHERE Host = 'some_host' AND User = 'some_user';
mysql> FLUSH PRIVILEGES;

, ma ho sempre lo problema.
Sul server funziona, ma non in locale. Forse devo installare qualcosa che è presente sul server?
Aiutatemi sono due giorni che sto impazzendo.

Brainkiller Profilo | Guru

>Ciao a tutti
>Hoil seguente problema. Quando accedo al mio db mysql(versione
>5) ricevo il seguente messaggio:
>'Client does not support authentication protocol requested by
>server; consider upgrading MySQL client'

Ciao,
il messaggio d'errore mi sembra abbastanza diretto. Da quello che ne capisco io stai utilizzando un client (eseguibile) che non è allineato alla versione del Server. Può essere ? Quindi parlano due linguaggi diversi, MySQL 5 si aspetta dei dati e il client invece è 4.x ne manda altri.
Aggiorna il client, prendendolo da una installazione di MySQL 5 funzionante.
Ciao

David De Giacomi
Microsoft MVP
http://blogs.dotnethell.it/david/
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5