Debug

mercoledì 30 novembre 2005 - 12.33

drigo83 Profilo | Senior Member

Ciao a tutti, ho un problema. Quando cerco di debuggare il compilatore non mi si ferma ai breakpoint . Questo mi capita in un paio di form. Se per esempio prima entro in un form e poi nell'altro allora si ferma.

Qualche idea?

Grazie

Brainkiller Profilo | Guru

>Ciao a tutti, ho un problema. Quando cerco di debuggare il compilatore
>non mi si ferma ai breakpoint . Questo mi capita in un paio
>di form. Se per esempio prima entro in un form e poi nell'altro
> allora si ferma.

Di solito i motivi possono essere due:

1) Stai cercando di debuggare con un progetto in modalità Release e non Debug.

2) Tu sei convinto che il codice debba passare di lì, invece in realtà non ci passa quindi non si ferma. Prova a mettere ulteriori breakpoint durante il Load della Form per esempio o in chiusura di Form.

Ciao

David De Giacomi
Microsoft MVP
http://blogs.dotnethell.it/david/

drigo83 Profilo | Senior Member

Grazie per le tue risposte, ma non è per questi due casi, sono in modalità debug e il breakpoint è sul load del form. Come ho già detto la cosa strana è che si ferma solo se prima sono entrato in un'altro form.

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5