Sottoreport

martedì 06 dicembre 2005 - 12.01

AntCiar Profilo | Expert

Salve,

ho il seguente problema:

Ho creato due report R1 e R2 e tramite il metodo setDataSource gli associo due tabelle T1 e T2 precedentemente riempite di dati.

Aggiungo all'interno della sezione "Intestazione di pagina" di R1 il report R2 come sottoreport. seguo l'applicazione e al momento di visualizzare il report R1 mi compare i messaggio allegato in figura e se faccio annulla mi apre il visualizzatore vuoto.

Come posso risolvere?
Grazie.

Posto di seguito anche il codice che utilizzo: (viewer è il Crystal Report Viewer)

Dim R2 As New ValoriAnag
Dim R1 As New AnalisiRisultati

R2.SetDataSource(Me.DSAnagrafica.Tables(0))
R1.SetDataSource(Me.DSValori.Tables(0))
Me.Viewer.ReportSource = R1

totti240282 Profilo | Guru

ricerca nel foro tableofinfo se ricordo bene,è gia stato trattato a dovere.

C'è solo un capitano !!!!!!

Brainkiller Profilo | Guru

>Come posso risolvere?
>Grazie.

Prova ad utilizzare la tecnica nel post di scarface in questo Thread:
http://www.dotnethell.it/forum/messages.aspx?ThreadID=420

Se cerchi nel Forum TableLogonInfo trovi altri Thread.
ciao

David De Giacomi
Microsoft MVP
http://blogs.dotnethell.it/david/
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5