Problema applicazione client/server

venerdì 09 dicembre 2005 - 20.51

AntonioM Profilo | Junior Member

Salve a tutti,
ho sviluppato una piccola applicazione client/server e ho un problema lanciandola dal client che teneta di aprire la connessione ad un db SQL (fatto con MSDE) sul server... potrebbe essere sbagliata la stringa di connessione???
In allegato c'è l'errore....
Grazie in anticipo

Antonio.

Cteniza Profilo | Guru

Mi sembra ovvio.
Hai fatto partire il server?
E l'autenticazione com'è (mista, solo windows, solo sql server), meglio la prima
Se il server non è in locale hai dato le autorizzazioni del caso?.


AntonioM Profilo | Junior Member

Hai ragione ho fornito pochi dettagli...
l'applicazione client deve accedere al db che si trova su un'altra macchina collegata in rete con la prima. Sulla macchina client c'è win98, explorer 5.2, MDAC 2.7 oltre al framework 1.1. Sul server gira XP Pro SP2, VS2003, MSDE.
Non ho ben capito cosa intendevi con "autenticazione" invece per quanto riguarda le autorizzazioni ho impostato "full trust" sulla macchina client...

Cteniza Profilo | Guru

Guarda che è il server che devi configurare perchè i client si possano collegare.


AntonioM Profilo | Junior Member

Cosa dovrei fare per configurarlo? (scusa l'ignoranza...)

Cteniza Profilo | Guru

Quantomeno devi impostare la modalità di accesso / autenticazione su sql server.
In ogni caso l'operatore (o il pc) vanno autorizzati nella macchina server.


AntonioM Profilo | Junior Member

Come faccio ad impostare la modalità di accesso / autenticazione su sql server?

Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5