Porte "Stealth" con Windows Xp

mercoledì 19 aprile 2006 - 16.39

maurizio79 Profilo | Junior Member

Ciao a tutti.
Ho avuto un problema con un portatile, Win XP Pro e IIS. Diciamo che ora ho risolto, ma un domani non vorrei incontrare lo stesso tipo di intoppo.
Dovevo configurare un router con la nuova linea ADSL. Avevo 5 IP pubblici a disposizione, quindi ho fatto in modo che il portatile in questione avesse uno di questi con tutto aperto e facesse girare una paginetta web sul sito principale (ovviamente era solo la prima fase di test, mentre lavoravo a vuoto staccavo la rete). Tutto a posto, tranne per il fatto che da fuori non visualizzavo la pagina e su www.grc.com (test delle porte) mi diceva che tutte le porte di quell' indirizzo erano "Stealth", ovvero irraggiungibili. Ho perso una giornata pensando che dipendesse dal router, prima di provare con un server win2k per scoprire che il problema era solo sul portatile.
Il portatile aveva il firewall disattivato, nessun programma particolare ed addirittura Norton disattivato per la maggior parte del tempo. Da cosa poteva dipendere?

Ciao e grazie, Maurizio

Brainkiller Profilo | Guru

>Il portatile aveva il firewall disattivato, nessun programma
>particolare ed addirittura Norton disattivato per la maggior
>parte del tempo. Da cosa poteva dipendere?

Ciao,
secondo me può dipendere dal fatto che sul router non è stata fatta la mappatura delle porte quello che si chiama Port Redirection. Ossia ossia se uno apre l'indirizzo 200.200.200.200 bisogna configurare che il traffico venga indirizzato al computer interno alla LAN (notebook o fisso) con IP per esempio 192.168.0.10.
Probabilmente il server di cui parli ha già la mappatura creata quindi il traffico arriva direttamente lì.
Se tu chami un IP il router deve sapere poi a chi instradare i pacchetti. se ci sono 50 macchine nella LAN come fa a saperlo ? Devi dirglielo tu.

Ciao

David De Giacomi
Microsoft MVP
http://blogs.dotnethell.it/david/

maurizio79 Profilo | Junior Member

Questo è chiaro. Il router era configurato perfettamente, tanto che è bastato attaccare un' altra macchina Win2K con lo stesso IP e tutto è andato OK.
Il problema era sul portatile, che nascondeva le porte mentre io volevo renderle disponibili.

Ciao e grazie, Maurizio

Brainkiller Profilo | Guru

>Questo è chiaro. Il router era configurato perfettamente, tanto
>che è bastato attaccare un' altra macchina Win2K con lo stesso
>IP e tutto è andato OK.
>Il problema era sul portatile, che nascondeva le porte mentre
>io volevo renderle disponibili.

Ok a questo punto sarà un problema di tipo software. Evidentemente c'è dell'altro oltre a norton e al firewall software che blocca. Non vedo altre soluzioni al problema.
CIao

David De Giacomi
Microsoft MVP
http://blogs.dotnethell.it/david/

maurizio79 Profilo | Junior Member

>Non vedo altre soluzioni al problema.

E' proprio questo il problema...

Comunque meno male che tutto si aggira, in questi casi.

Ciao!
Ciao e grazie, Maurizio
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5