Installazione reporting services evalutaion per sql server 2000 su win...

venerdì 21 aprile 2006 - 11.52

teoteo Profilo | Newbie

Ciao a tutti,
mi sono imbattuto in un problema per il quale non sono riuscito a trovare uno straccio di soluzione.

Premessa
Ho installato i reporting services eval in locale, sulla mia stazione di sviluppo (win xp & sql server 2000 dev edition). Tutto ok.


Problema
mi accingoad installare la sopracitata versione eval sul server di produzione
win 2003, sql server 2000 standard edition sp4.
Tutti i requsiti hardaware e software sono soddisfatti (iis, asp.net etc..). L'utlimo step dell'installazione mi comunica che

"questa edizione del database di server non è supportata nell'edizione di sql server 2000 selezionata. Selezionare un edizione di sql server che soddisfi i requisiti"

fine.... ora mi chiedo, QUALI REQUISITI?!?! ma aggiungere uno straccetto di dettaglio in questi criptici messaggi?

sono due giorni che ci sclero, qualche anima pia saprebbe darmi una dritta?
Grazie per l'Attenzione

freeteo Profilo | Guru

ciao,
si effettivamente la cosa è 1po fastidiosa, concordo con te che non sia il massimo...
Cmq è facile capire che tu avendo la developer edition di sql server probabilmente hai anche la developer edition dei sqlreporting, quindi nel deploy su standard viene fatto questo controllo e quindi dato questo messaggio.
Infatti se dai 1occhiata qui: http://www.microsoft.com/sql/prodinfo/previousversions/rs/system-requirements.mspx
quando parla di versioni di sql, al rimando n.ro 4,5,6 dice testuale:
"...Use the edition of SQL Server 2000 that corresponds with the edition of Reporting Services you will be running...."
e sembra proprio questo il tuo problema...

Ti consiglio percio' di cercare la versione di reporting uguale a quella del server su cui fai il deploy, guardando sui download disponibili di Microsoft, te ne do alcuni che ti potrebbero tornare utili:
http://www.microsoft.com/downloads/details.aspx?familyid=502C0D89-1308-4662-8F58-CEC55EF1235B&displaylang=it
http://www.microsoft.com/downloads/details.aspx?displaylang=it&FamilyID=502C0D89-1308-4662-8F58-CEC55EF1235B
http://www.microsoft.com/downloads/details.aspx?familyid=BA517C01-2E2F-4BC7-84AF-149B7637F807&displaylang=it

ps: ad esempio nella versione 2005 di reporting services legata a sql 2005 (o express) puoi aggirare il problema usando la "versione locale" ovvero usando i LocalReport (file rdlc da caricare a runtime) che ti permettono di distrubuire sotto la directory "bin" le librerie di runtime che servono all'elaborazione, senza avere queste "scocciature" :
http://msdn2.microsoft.com/en-US/library/ms251723.aspx

Ti bastano questi 4 assembly copiabili dal tuo disco per far andare 1applicazione web con reporting servicies, e poi non ti interessa che tipo di database hai, tanto gli passi 1 datasource che puoi customizzare...Questa tipologia pero' non si appoggia ad 1 reportserver e quindi ha delle limitazioni, ma magari per te puo anche bastare, dacci cmq 1occhiata



ciao.

Matteo Raumer
MCAD ... .net addicted :-)
http://blogs.dotnethell.it/freeteo

teoteo Profilo | Newbie

grazie per la risposta,

>ciao,
>si effettivamente la cosa è 1po fastidiosa, concordo con te che
>non sia il massimo...
>Cmq è facile capire che tu avendo la developer edition di sql
>server probabilmente hai anche la developer edition dei sqlreporting,
>quindi nel deploy su standard viene fatto questo controllo e
>quindi dato questo messaggio.

ma (c'è sempre un ma) la versione che ho installato sulla workstation senza il minimo problema è quella scaricata dal sito microsoft, ed è anche la stessa con cui stò bestemmiando in lingue morte per installarla sul server.

Per sfizio ho anche tentato di scaricare la versione di reporting services in inglese (sempre dal sito) ma l'installazione si ferma sempre allo stesso punto.....

Il problema è che per farla acquistare (reporting services) volevo appunto installarla sul server per far vedere al mio capo i potenziali sviluppi... quindi ecco perchè utilizzo la eval.

Mi è venuto un orribile sospetto:
sul server, win 2003 è in italiano, sql server 2000 standard edition è in inglese, ed ho provato ad installare rseval sia in italiano (ita_rseval.exe) che in inglese (rseval.exe).

A parte il fatto che entrambe le installazioni partono in italiano (e credo che sia dovuto alla localizzazzione del sistema operativo)... insomma potrebbe essere questo accrocchio babilonese di lingue a creare problemi?

Grazie per la Collaborazione.


freeteo Profilo | Guru

ciao,
adesso non ricordo bene ma i reporting services non venivano dati "in omaggio" con la versione di sql? Perche non mi sembra di ricordare che si potessero comprare come pacchetto agiuntivo, pero' probabilmente mi sbaglio...

Cmq al momento non saprei che dirti se non di provare a controllare bene cosa dice la bibbia :
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/RSINSTALL/htm/gs_ins_overview_v1_3rky.asp?frame=true

e verificare che magari non sia stato risolto con il sp1 di sqlreporting:
http://www.microsoft.com/downloads/details.aspx?FamilyId=580FEBF7-2972-40E7-BCCF-6CD90AC2F464&displaylang=en

anche se, a quanto pare, nel tuo server è stato installato anche il db per il server di reporting e quindi il pacchetto che installi tu ne trova gia 1o presente che non gli va a genio la cosa...
Provare a reinstallare tutto da capo? magari se puoi farlo in virtual machine capisci bene dove è l'inghippo e poi riporti la soluzione in ambiente lavorativo...

Al momento non saprei dirti altro...

ciao.

Matteo Raumer
MCAD ... .net addicted :-)
http://blogs.dotnethell.it/freeteo
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5