Crystal Reports - web component server

mercoledì 03 marzo 2004 - 10.52

giorgiogt Profilo | Newbie

Salve, mi chiamo Giorgio. Sto costruendo un sito intranet sfruttando il web component server di Crystal Reports. Il mio problema nasce quando apro un report da un client (con internet explorer) e devo inserire i dati della connessione sql:
-NOME UTENTE: sa
-PASSWORD:(nessuna)
Questi me li da in automatico:
-NOME SERVER:ARIETE(come mai mi indica il nome del database e non del server che è SERVER?)
-NOME DATABASE:ARIETE

Se digito il nome utente SA non me lo accetta, mentre se apro un report con Crystal Reports mi accetta il nome utente SA.
Ho provato a creare un nuovo utente su sql server con password ma non c'è niente da fare.
Forse dipende dall'impostazione del utente in SQL Server?

Vi ringrazio, saluti.

Giorgio

Brainkiller Profilo | Guru

Ciao Giorgio,
Crystal è un prodotto molto delicato che spesso crea rogne per lo sviluppatore. Recentemente Microsoft ha messo a disposizione uno strumento chiamato SQL Reporting Services molto rapido che fa le stesse cose di Crystal, anzi di più, e molto meglio, se puoi dacci un'occhiata.

Ti ricordo che le credenziali di accesso al DB non vengono mai inserite nel file del report .crt ma bisogna applicare a runtime di volta in volta con l'istruzione SetDatabaseLogon. Qui trovi dei post in cui si discute il problema:

http://www.dotnethell.it/forum/messages.aspx?ThreadID=603
http://www.dotnethell.it/forum/messages.aspx?ThreadID=105
http://www.dotnethell.it/forum/messages.aspx?ThreadID=348

Se non l'hai già letto c'è anche questo articolo:
http://www.dotnethell.it/articles/article.aspx?ArticleID=87

Fammi sapere se ce la fai.
ciao
david
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5