Login Wizard E Problemi....

venerdì 09 giugno 2006 - 15.17

LeonDom Profilo | Senior Member

Ho questo problema con un Login Wizard...

Nel mio portatile, http://localhost mi funziona tutto, ma quando vado a trasferirlo su server (W2003) nella cartella virtuale appositamente creata mi va in errore...

Naturalmente il file viene messo nella cartella /App_Data/ con all'interno il database sql2005 creato con gli user e le password con il wizard, ho creato solo una zona controllata (cartella /area/) che funziona, infatti se provo l'accesso ad una di quelle pagine mi redirect su login.aspx, appena tento l'accesso mi va in errore....

cosa sbaglio, permessi di scrittura e lettura anche su quella cartella interna? o che so io?





LeonDom

GvnnRules Profilo | Senior Member

Potresti postare il messaggio di errore?

Peace
Gvnn

http://www.gvnn.it
http://www.sqlwebarchitect.org
http://blogs.dotnethell.it/gvnn/

LeonDom Profilo | Senior Member

Errore server nell'applicazione '/RAS'.
--------------------------------------------------------------------------------

Errore di runtime
Descrizione: Errore di un'applicazione sul server. Per motivi di protezione, le attuali impostazioni personalizzate relative agli errori dell'applicazione impediscono di visualizzare in modalità remota ulteriori dettagli sull'errore riscontrato. Tali dettagli possono essere tuttavia visualizzati nei browser eseguiti localmente sul server.

Dettagli: Per attivare la visualizzazione dei dettagli di questo messaggio di errore specifico sul server remoto, creare un tag <customErrors> in un file di configurazione "web.config" memorizzato nella directory principale dell'applicazione Web corrente. L'attributo "mode" del tag <customErrors> deve essere impostato su "Off".


Non riesco neanche a mettere una pagina di errore personalizzato....





LeonDom

GvnnRules Profilo | Senior Member

Domanda ... ma hai impostato il sito web per il framework 2.0? perchè è strano che in locale vada, e online no ... prova a vedere sotto le proprietà del sito su iis nella linguetta asp.net

... moooooolto strano

Peace
Gvnn

http://www.gvnn.it
http://www.sqlwebarchitect.org
http://blogs.dotnethell.it/gvnn/

LeonDom Profilo | Senior Member

si l'ho impostato...

ti dico come sta la configurazione di IIS...

ho un sito nella intranet con nome \\mioserver

ho creato poi una cartella virtuale \\mioserver\miacartella

l'ho impostata con il Fram2.0

Nella cartella miacartella ci sono ovviamente tutte le pagine aspx e le altre sottocartelle...

devo impostare qualche permesso particolare sulla cartella App_Data????

Altre note... sul server non c'è SQL2005Express, naturalmente sto cercando di usare quello creato da VS nella cartella dell'applicazione App_Data


Nel Frattempo ho fatto un po' di prove e sono andato avanti...
ho creato una pagina di errore, che ora sembra gestirmi, naturalmente non mi da nessun messaggio perché è vuota, ma sulla barra dell'indirizzo compare quanto segue....

http://mioserver/miacartella/DefaultError.aspx?aspxerrorpath=/miacartella/login.aspx

GvnnRules Profilo | Senior Member

Il fatto è che da quell'errore non è che si capisca molto ... l'utente asp.net deve avere i permessi per accedere alle varie cartelle, ma credo che basti una lettura ... prova a dare full control all'utente asp.net sulla cartella del sito, ma ho i miei dubbi che cami qualcosa ... ma nemmeno modificando il web.config come dice nel messaggio di errore compare qualcosa di + dettagliato? Magari potresti mettere nella pagina che ti da errore un try/catch per vedere se è la pagina, oppure è un problema di configurazionee + generale ... sempre + stranoooooooooooo

Peace
Gvnn

http://www.gvnn.it
http://www.sqlwebarchitect.org
http://blogs.dotnethell.it/gvnn/

LeonDom Profilo | Senior Member

Ho provato ad aggiungere qualche riga nel web.config, ma non va ancora... ti posto il web.config:

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
<appSettings/>
<connectionStrings>
<add name="ASPNETDBConnectionString1" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\ASPNETDB.MDF;Integrated Security=True;User Instance=True"
providerName="System.Data.SqlClient" />
</connectionStrings>
<system.web>
<!--
Impostare compilation debug="true" per inserire i
simboli di debug nella pagina compilata. Poiché tale operazione ha effetto
sulle prestazioni, impostare questo valore su true
solo durante lo sviluppo.
-->
<customErrors defaultRedirect="~/DefaultError.aspx" />
<trace enabled="true" localOnly="false" />
<roleManager enabled="true" />
<compilation debug="true"/>

<authentication mode="Forms">
<forms name="credit" path="/" loginUrl="Login.aspx" protection="All" timeout="30" />
</authentication>
<customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>
-->
</system.web>
</configuration>

Sul server ho provato ad impostare FullControl su user ASPNET, ma nonè cambiato nulla... la cosa che mi fa ink.... è che in locale funziona benissimo....


LeonDom

GvnnRules Profilo | Senior Member

Prova a cambiare

<customErrors defaultRedirect="~/DefaultError.aspx" />...</customErrors>
in
<customErrors mode="Off"/>

ahh ... poi io per gli errori metto qualche riga nel global.asax nella sub Application_Error

Dim objErr As Exception = Server.GetLastError().GetBaseException() Dim err As String = "<html><body><b>Error Alert</b><hr>" _ & "<br><b>Error URL: </b>" & Request.Url.ToString() _ & "<br><b>Error Message: </b>" & objErr.Message.ToString() _ & "<br><b>Error Stack:</b><br>" & objErr.StackTrace.ToString() _ & "<p><a href=""javascript:self.location.reload();"">Reload page</p>" _ & "</body></html>" Response.Write(err.ToString()) Server.ClearError()

prova ... ci credo chee ti faccia incazzare ... il fatto è che è troppo criptico l'errore

Peace
Gvnn

http://www.gvnn.it
http://www.sqlwebarchitect.org
http://blogs.dotnethell.it/gvnn/

LeonDom Profilo | Senior Member

Ho messo l'off come mi hai detto tu... e questo è il risultato dell'errore.... è SQL

Errore server nell'applicazion
--------------------------------------------------------------------------------

Si è verificato un errore mentre si cercava di stabilire una connessione con il server. Quando ci si connette a SQL Server 2005, questo errore potrebbe essere provocato dal fatto che l'SQL Server non ammette connessioni remote sotto le impostazioni predefinite. (provider: Interfacce di rete SQL, error: 26 - Errore nell'individuazione del server/dell'istanza specificata)
Descrizione: Eccezione non gestita durante l'esecuzione della richiesta Web corrente. Per ulteriori informazioni sull'errore e sul suo punto di origine nel codice, vedere l'analisi dello stack.

Dettagli eccezione: System.Data.SqlClient.SqlException: Si è verificato un errore mentre si cercava di stabilire una connessione con il server. Quando ci si connette a SQL Server 2005, questo errore potrebbe essere provocato dal fatto che l'SQL Server non ammette connessioni remote sotto le impostazioni predefinite. (provider: Interfacce di rete SQL, error: 26 - Errore nell'individuazione del server/dell'istanza specificata)

Errore nel codice sorgente:


Sto Disperato....

LeonDom

GvnnRules Profilo | Senior Member

Già abbiamo scremato gli errori ... non riesce a collegarsi ... possibili cause:

1. Indirizzo sbagliato
2. credenziali d'accesso sbagliate (login, password, database)
3. Errore nella configurazione della rete dei client ... probabilmente sbagli a scrivere il nome dell'istanza nella stringa di connessione o non è configurato correttamente
4. Non è attiva l'autenticazione tramite odbc ... sai ci sono 2 tipi di connessione, trusted che utlizza gli utenti del sistema operativo, o quella tramite odbc, o chi per esso, dove passi le credenziali dell'utente del db

.... per adesso non me ne vengono in mente altre

Peace
Gvnn

http://www.gvnn.it
http://www.sqlwebarchitect.org
http://blogs.dotnethell.it/gvnn/

LeonDom Profilo | Senior Member

Fatte un po' di prove senza alcun risultato, quando lo utilizzo in locale funziona alla perfezione, quando lo utilizzo su server non va...

Ci rinuncio?

Bestia Profilo | Newbie

hai provato a vedere quali database di Membership e di Role provider hai nel webconfig? forse sul server hai attivo l'aspnet provider mentre sul webconfig hai attivo l'xmlprovider...ciao
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5