Home Page Home Page Tips & Tricks La funzione SE di Excel

La funzione SE di Excel


Questa funzione restituisce un determinato valore se la condizione specificata ha valore VERO e un altro valore se essa ha valore FALSO. E’ una funzione da utilizzare per eseguire test condizionali sia su valori che su formule in Excel.

La Sintassi è:

SE(test; se_vero; se_falso)

Test è un valore o un'espressione che può dare come risultato o VERO o FALSO.
Se_vero contiene il valore da assegnare a una cella se la condizione di cui sopra ha come valore VERO.
Se_falso contiene il valore da assegnare a una cella se la condizione di cui sopra ha come valore FALSO.

Alcuni esempi pratici per capire la formula in maniera più immediata.

1) se_vero e se_falso restituiscono una parola (SI o NO) in base al valore della condizione.

In A6 è stata inserita questa formula:

=SE(B4<=100;"SI";"NO")

In modo che appaia "SI" se le rimanenze (B4) sono uguali o inferiori ai 100 pezzi, altrimenti "NO".



2) se_vero e se_falso restituiscono un valore, necessario per calcolare altre funzioni correlate alla cella stessa.
La situazione originaria è nella figura a sinistra: abbiamo un capitale, un periodo ed è stata inserita la formula per calcolare la rata mensile da pagare. Manca il tasso d’interesse. Tasso che vogliamo abbassare per agevolare chi resituisce il capitale in meno di 120 mesi, 5%. Se si eguagliano o superano i 120 mesi il tasso sarà del 6%. In B4 si puo’ inserire la formula:

=SE(B3>120;6%;5%)

Il risultato è quello che si vede nell’immagine a destra:



3) se_vero restituisce un determinato valore, se_falso nidifica all’interno altre funzioni SE.
Abbiamo una tabella che va a specificare una lettera per ogni classe di reddito. Bisogna capire se il reddito del signor Rossi è di classe A,B,C,D o E. Quindi paragoneremo il suo reddito contenuto in B9 con la prima classe di reddito (A3 e B3), imponendo come condizione l’essere maggiore o uguale a 0 euro e minore o uguale a 7000 euro [ E(B9>=A3;B9<=B3) ].

Se soddisfa questa condizione dovrà apparire "A". Altrimenti si passa alla seconda possibilità, nidificando una seconda funzione SE nella sezione se_falso, e così via, fino alla classe E se si superano i 50.000 euro. La formula da inserire in C9 è quindi:

=SE(E(B9>=A3;B9<=B3);C3;SE(E(B9>=A4;B9<=B4);C4;SE(E(B9>=A5;B9<=B5);C5;SE(E(B9>=A6;B9<=B6);C6;"E"))))



Ovviamente se vogliamo trascinare/copiare la formula nelle celle sottostanti, dobbiamo modificarne i riferimenti, in modo da renderli assoluti utilizzando il dollaro $:

=SE(E(B9>=$A$3;B9<=$B$3);$C$3;SE(E(B9>=$A$4;B9<=$B$4);$C$4;SE(E(B9>=$A$5;B9<=$B$5);$C$5;SE(E(B9>=$A$6;B9<=$B$6);$C$6;”E”))))

In modo da ottenere:



Queste sono solo alcune delle possibilità di utilizzo della funzione SE. E' vivamente consigliato consultare la Guida In Linea di Excel (premendo F1) per avere informazioni a riguardo dei limiti della funzione e delle altre possibilità riguardo all’utilizzo della stessa.

Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5