Transaction Log pieno

lunedì 17 dicembre 2007 - 22.41

leonardop Profilo | Junior Member

Salve a tutti.
ho un problema con i files di log.
Alla richiesta di cancellazione di righe da una tabella ottengo questo messaggio di errore:
Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

Ho provato a seguire i consigli riportati in questo Thread
http://www.dotnethell.it/forum/messages.aspx?ThreadID=10763
ossia
BACKUP LOG NOME_DB WITH NO_LOG
DBCC SHRINKFILE (NOME_LOG_FILE, 10)
ma niente.

potete aiutarmi??
leonardo
http://blogs.dotnethell.it/leonardo/

lbenaglia Profilo | Guru

>Alla richiesta di cancellazione di righe da una tabella ottengo
>questo messaggio di errore:
>The transaction log for database 'xxxxx' is full. To find out
>why space in the log cannot be reused, see the log_reuse_wait_desc
>column in sys.databases
>
>Ho provato a seguire i consigli riportati in questo Thread
>http://www.dotnethell.it/forum/messages.aspx?ThreadID=10763
>ossia
>BACKUP LOG NOME_DB WITH NO_LOG
>DBCC SHRINKFILE (NOME_LOG_FILE, 10)
>ma niente.
>
>potete aiutarmi??

Ciao Leonardo,

I comandi che riporti sono corretti e DEVONO funzionare
Dato che il problema si verifica con una cancellazione massiva, mi sorge il dubbio che sia disattivata l'autoextension del transaction log oppure che lo spazio fisico del volume che ospita il file .ldf sia terminato.

Prova a verificare...

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/
http://italy.mvps.org

leonardop Profilo | Junior Member

Il codice sorgente non è stato renderizzato qui
perchè non c'è sufficiente spazio.
Clicca qui per visualizzarlo in una nuova finestra

scusa l'ignoranza da dove controllo??
utilizzo SSMS per la gestione del db . il provider è webhostforasp.net

grazie..
leonardo
http://blogs.dotnethell.it/leonardo/

lbenaglia Profilo | Guru

>scusa l'ignoranza da dove controllo??
>utilizzo SSMS per la gestione del db . il provider è webhostforasp.net

Per quanto riguarda l'autoextension da SSMS seleziona il db, tasto DX, Properties, Files ed osserva la colonna Autogrowth.
Seleziona il t-log, fai click su "..." e verifica se la check box "Enable Autogrowth" sia abilitata o meno. Inoltre verifica se è stato impostato il "Restricted File Growth".

Se il db si trova in hosting è molto probabile che abbiano disabilitato l'Autogrowth impostando una dimensione massima.

Se è questo il caso, hai due soluzioni:

- Chiedi di estendere la dimensione del t-log (pagando in base alle nuove dimensioni)
- Elimina meno righe alla volta, in modo da creare transazioni più piccole che non facciano collassare il t-log.

>grazie..
Prego.
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/
http://italy.mvps.org

leonardop Profilo | Junior Member

scusa il ritardo nella risposta ma l'influenza mi ha stroncato..
utilizzo la versione italiana di ssms. non mi ritrovo "Enable Autogrowth" ne "Restricted File Growth"

"compattazione automatica"??

grazie!



leonardo
http://blogs.dotnethell.it/leonardo/

lbenaglia Profilo | Guru

>utilizzo la versione italiana di ssms. non mi ritrovo "Enable
>Autogrowth" ne "Restricted File Growth"
>
>"compattazione automatica"??
No, quella opzione corrisponde ad "Auto Shrink" nella pagina "Options".
Putroppo non ho a disposizione SSMS in italiano, ma in precedenza ti ho scritto che devi consultare la pagina "Files"

>grazie!
Prego.

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/
http://italy.mvps.org
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2023
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5