Crystal report XI R2 VS 2008

mercoledì 10 marzo 2010 - 16.12

JANLU79 Profilo | Newbie

Ciao,
Sono nuovo del forum ed avrei un esigenza.
Con VS 2008 ho creato una form per lanciare un report crystal versione XI R2.
Il codice è il seguente:

Dim crViewer1 As New CrystalActiveXReportViewerLib11_5.CrystalActiveXReportViewer
Dim crAPP As New CRAXDDRT.Application
Dim Report As New CRAXDDRT.Report
Report = crAPP.OpenReport("c:\fatture.rpt", 1)
Report.EnableParameterPrompting = True
Report.EnableParameterPrompting = True
Report.DiscardSavedData()
Report.Database.LogOnServer("p2ssql.dll", "GIANLUCA-7\DOLPHIN", "xxx", "xxx", "xxx") ' ovviamente xxx è per cryptare le credenziali
With crViewer1
.EnableExportButton = True
.EnablePrintButton = True
.EnableCloseButton = True
.ReportSource = Report
.Zoom(100)
.RefreshEx(True)
.ViewReport()
.Refresh()
End With

Il codice non dà errori ma il report non parte .... qualche idea?

Grazie

freeteo Profilo | Guru

Ciao,
cosa intendi per "non parte", ti si visualizza ma è bianco?
La barra del viewer con i bottoni si vede correttamente (tipicamente indica che il report è stato caricato) ma poi il corpo del report è bianco? Si vedono solo le label che hai messo fisse nel report?

Queste domande per capire se il report è vuoto ossia non carica i dati, oppure se il report non è stato nemmeno caricato dal viewer...

Ciao.

Matteo Raumer
[MCAD .net, MVP Visual C#]
http://blogs.dotnethell.it/freeteo
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5